Phone Doesn't Charge

armiesahagunarmiesahagun Level 1
edited October 2021 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG 5 16 - 256
  2. Firmware Version: Wasn't able to check
  3. Rooted or not: Not
  4. Frequency of Occurrence: Once
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Got the phone for a month now(going 2 months on Sept 27). No issues whatsoever except when I tried charging it this morning, it showed charging(not the usual Quick Charge) but the battery level doesn't go up, instead it goes down till the point it was drained. Now I have a dead phone who doesn't respond to the charging brick.

I don't think the issue is with the charging brick as I tried a different phone with it and it charges perfectly. Tried other charging bricks with the ROG and it shows no reaction whatsoever.

Any help would be very much appreciated.


This discussion has been closed.