Spontaneous "Can't load Android system" Error on ROG Phone 2

kyleskyles Level 1
edited September 11 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: Rog Phone 2
  2. Firmware Version: Latest - WW-17.0240.2107.100
  3. Rooted or not: not rooted
  4. Frequency of Occurrence: every single power up
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Phone updated via OTA a few days ago and everything seemed to go well with no issues until now. Pulled the phone out of my pocket to see the below screen:


Android Recovery

asus/WW_I001D/ASUS_I001_1

10/QKQ1.190825.002/17.0240.2107.100-0

user/release-keys

Use volume up/down and power.

Can't load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factor data reset and erase all user data stored on this device.


Now after every single power on attempt the phone will go through the normal boot process and splash screens but then just displays a black screen with the bottom navigation bar blinking on and off for a few seconds. The phone then powers itself off and back on again and I get the same above "Android Recovery" info.

I can use the Power + Up Volume buttons to get into fastboot mode and then select Recovery Mode but none of the options there have helped. I've used this guide https://www.thecustomdroid.com/sideload-ota-update-stock-recovery-adb/ to attempt to sideload the latest firmware and get everything working again. I don't have any windows computers so I've been using my Manjaro laptop to run all the adb commands. This process seems to go smoothly but upon restart the phone still has the same exact problems with no change. I've attempted to sideload every WW firmware version available from here https://rog.asus.com/phones/rog-phone-ii-model/helpdesk_bios. The sideloading process seems to go fine with no errors but upon restart there is no change at all and the Android Recovery still shows the WW-17.0240.2107.100 version no matter what version I just sideloaded.

I would really love to be able to get the phone working again without any data loss or having to wipe anything. I don't have a recent backup to restore from. I do not think that I have USB debugging enabled so I believe that limits my ability to rescue any user data. If I have to wipe everything and start with a fresh install, is there any way at all to rescue hopefully all of the user data from the phone? I've been googling for a couple of days to try and solve this myself but I don't know what else to try without having to wipe everything and start over from scratch.

Best Answer

This discussion has been closed.