Zenbook UX325EA audio driver memory leak

edited August 9 in ZenBook


  1. System: Windows 10 Enterprise 2019 LTSC (1809, Build 17763.1999), also tried Windows 10 Home Single language (21H1, build 19043.1052) and Windows 11 Home Single language (Insider Preview build 22000.51);
  2. Battery or AC: both;
  3. Model: Zenbook UX325EA-KG276T;
  4. Frequency of occurrence: every boot;
  5. Reset OS: yes, reset and even full reinstall doesn't help;

========================

Detailed description:

Hello, recently I bought my new Zenbook laptop. After few days I noticed, that RAM is completely full, but I has only browser with several tabs opened. Thinking that it can be some random problem, I just tried to reboot, but every boot RAM filled in after approximately an hour, then system becomes very slow and unresponsive. There are no background services or apps, that can take so much memory, and also I disabled autostart for all apps, installed on my own. I tried to find out cause of the problem using task manager (builting and fird-party) and resource monitor, but none of running processes drains so much memory. Then I used Poolmon to find, that EtwD (Paged pool) and Etwr (None-paged pool) pool tags take about 5 GB of RAM (I have 8 GB). So I got trace using xperf and analyzed it with WPF. finally, I found out, that functions from audioserv.dll allocated so much stack memory.

For clarification, I've updated all drivers with My ASUS tool and standard Windows Update, also I've installed latest available BIOS (307). I tried to reset the OS and even reinstall it. I used latest available audio driver (version 9088.1 from official ASUS support page), memory leak happened on preinstalled Windows 10 Home Single language, on Windows 10 Enterprise 2019 LTSC installed on my own and even on preview build of Windows 11 (updated from preinstalled OS or clearly installed from ISO).

I tried to install previous version of audio driver (9008.1) from ASUS support page -- leak also happened, but with audiodg.exe process, and restarting Windows Audio Service clears allocated memory (restarting this service with latest driver doesn't change anything). I tried to downgrade already installed driver and also install this (9008.1) version on newly installed OS (all three variants) -- nothing changed.

Then I once again reinstall windows and tried to install latest audio driver (version 9136.1) from Zenbook UX325 (10-TH intel processor) support page (I have UX325EA (11-th Intel Processor)) -- all audio enhancements are gone, but problem was also completely fixed, no leaks during few days. I also checked this driver (version 9136.1) on latest Windows 10 Home Single language (21H1) and on preview build of Windows 11 -- regardless of OS everything works great.

I don't know, what was the cause of this issue and why driver from different model works without any problem, but I hope that it's can help someone, who also faced with such bug.

PS. After first reinstalling of OS I didn't install any fird-party software (only drivers, My ASUS tool and browser (I used Microsoft Edge)), so problem can't be caused by any of my apps.

Tagged:

Comments

This discussion has been closed.