Other callers gets echoes after .90

FreddetjFreddetj Level 1
edited July 2021 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Asus ROG Phone II WW (sweden) ZS660KL


Not rooted

Frequency 100%

Facebook Messenger (all tested versions)

Since the last update any caller using messenger with me gets a very loud echo of themselves! Never had a problem with this and it started immediately after installing the latest FOTA.

Tried my other phones to rule out anything wifi or sim related. They work just fine, only The ROG phone 2 has the issue.

All mics works fine in .12345+=.

Tested several versions of the messenger app - all has the same echo.

Tested both 2.4 and 5ghz wifi, and also 3g and 4g. The same....

It's most severe on speaker phone and videocall. A slight echo in ordinary call.

I can hear the other caller just fine. It seems that the bottom speaker just feeds the sound to the bottom left mic and right back to the caller.

Ordinary sim-based calls works fine without echoes, even on speaker phone.

Any help would be appreciated. This started instantly after updating the phone.


  • @Freddetj Thanks for reporting this. Can you help us out with a device log? I'll send you a PM, check your inbox. 🙂

  • Happening for me as well.

    Using the Google Phone app.

  • You just need to wait for the fix it's been happening with almost everyone , also I faced this problem while playing pubg when my frnds told me your voice keeps on decreasing and you are not audible . My earphones are working fine , wifi connection stable yet the same problem arises . Just wait for it this issue has been considered. Thankyou 👍🏻

  • Same here, tried all different network and WiFi.

    Telephone not rooted.

    Happen after last update...

    Whatsup are working without echo, Messenger can not be used, to much echo.

    Please come with fix.

    Rog2 Phone

This discussion has been closed.