Asus Ux325ja not charging after myAsus applied new firmware

Hi,


MyASUS app installed automatically newest firmware for charhing via usb-c. After installation usb-c doesn't work, it's not charging and Device Manager shows UMC UCSI ACPI driver error.


Any ideas how to fix it?

Comments

  • Hi there,

    May I have the firmware version and the error message?

    Thank you.

  • Unfortunately I can't say because the battery is empty and it won't boot up.

  • MotoWiZMotoWiZ Level 2

    Hi,

    Perhaps it's just a coincidence, but have you tried with another charger?

    It won't charge even when the laptop is turned off?

    Have you tried in both USB-C with the laptop turned off with closed lid?

  • It won't charge even when off. Tried with lid closed aswell but didn't work.

    Tried both ports. Only the USB port on the right works fine.

  • edited March 30

    Boot windows OS into safemode and try to charge again.

  • MotoWiZMotoWiZ Level 2

    Perhaps it's just a coincidence, but can you try with another charger?

  • Sir, it's not a software problem but rather hardware since it doesn't charge even when turned off.

  • Hello Enigma,

    May you try to disconnect all cable, then long press the power button for 40 seconds to see if the device show anything sign of booting?

    And does the power LED light up?

    Thank you.

  • It boots up as usual, power led is on. Battery led don't light up. Tried charging with samsung's usb-c charger but no luck.

    I would try reflashing the BIOS but since the charger is requred during the process it may be impossible to fix it.

  • at last try, uninstall the battery related two driver's from device manager, and restart windows OS.

    windows will automatically reconfigure battery drivers

  • MotoWiZMotoWiZ Level 2
    edited March 31

    Samsung's usb-c charger doesn't have enough power it requires a charge with 60~65W. AFAIK phone chargers won't work. Do you know anyone that can lend you to try, a Macbook Pro charger for example? Or you could go to a store that has laptops in exhibition and ask if you could try out one of the chargers... just an idea...

  • During the covid? Not possible. Everything is closed.

  • MotoWiZMotoWiZ Level 2

    So, the option you have is send it to repair/test at Asus repair center...

  • Hello Enigma,

    Please kindly send your device to our service center.

    Really sorry for the inconvenience caused.

    Thank you.

  • It's probably due to the firmware upgrade. Unfortunately there are limited options cause reflashing BIOS requires charger to be connected.

  • Yes, that's the same what I had in mind. I have already contacted Asus in my country over RMA and they will send a courier ASAP.

  • Received the laptop yesterday. Working as good as new. According to the info from ASUS some parts were replaced, no details which exactly. Probably the whole mainboard because after turning the laptop on for the first time it would pretty loud. Thermal paste needs some time to adapt.

Sign In or Register to comment.