Rog Phone 2 screen froze and 1 long beep then shutsdown.

humanenderhumanender Level 1
edited February 1 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 2
  2. Firmware Version: Latest android 10
  3. Rooted or not: no
  4. Frequency of Occurrence: First time
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Was on videocall when the screen suddenly froze with 1 long beep(about 5-10 sec) then screen black.

Can't turn on, can't charge, tried all the button combinations(holding power button, voldown+power, volup+power, volup+down+power).

But when I connect to my laptop using the side port(it pops as QUSB_BULK....)

Xiaomiflash can't detect it.

Tagged:

Comments

  • ronald1985ronald1985 127.0.0.1 Level 5

    Hold power button and then press vol + and then while keeping vol + pressed, press on vol - so that in the end you're holding all 3 buttons before the ROG logo.

    If this doesn't work, keep it on charge and then perform the combinations.

    If all else fails, go to Service Centre.

  • Already did that combination(holding for 15-20 sec) but still nothing, unfortunately got no service centre near where I live, and I have to go to the other city for one, but I can't cause we're still in lockdown(and they're close anyway).

    Saw some people waited for their battery to be completely drained then tried to charge it and it works.

    Some people didn't do anything and found their phone fixed itself.

This discussion has been closed.