Very scary occurrence after WW-17.0240.2007.27 fota

kyleashcraft86kyleashcraft86 Level 2
edited October 2020 in ROG Phone 2

I have the global 12/512 gb edition rog phone 2. It's not rooted never has been. I went to plug the aero cooler in and tried pressing the power button to turn on the screen. NOTHING. I removed the cooler tried plugging it in at the bottom usb port. NOTHING. I continually tried powering it up by pressing power button. STILL NOTHING. It wasn't charging or powering on. It was behaving like it was totally bricked. This goes on for 10 minutes. I tried holding the power button and the volume down key. After 5-10 seconds it powered back up like nothing happened. I never had anything ever happen like this before the latest update. Has anyone else experienced this? Or have a reason as to what occurred and why?

Comments

  • @kyleashcraft86 my phone is getting switch off while charging 😕and more heating problem in phone after update

  • ronald1985ronald1985 127.0.0.1 Level 5

    There was a guy who had the same issue as you but I dont think it ever came back again.

    Was your phone powered on at that time? How I read your post is that you couldnt turn the screen on when your phone is powered on.

    It could be you are facing black screen where you dont notice if the phone is on or off. When you are stuck, you cant have it on or off using the power menu button because it is unresponsive.

    By holding volume and power button, you are forcing a shutdown on the phone. For example on Windows PC, you are pressing and holding power button and not going through the menu on Windows.

    Did you feel heat on the back of the phone when it was not powering on?

    Also, did you have battery juice left over?

    Sounds like you are Ok now which is great.

  • I don't think it was a black screen because my back led wasn't on and I have it set to be on when the screen is on. I was at 56% battery and my device was powered on at the time. None of the led's would come on when I tried to plug it in either Luckily I'm not seeing or experiencing any issues as of now. Freaked me out pretty bad for the 10 minutes I was unable to get a response from my rog 2

This discussion has been closed.