Choppy animation on 4k main monitor

  1. System: Windows 10
  2. Battery or AC: Both
  3. Model: UX581GV
  4. Frequency of occurrence: Constant
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

Anyone getting choppy animations on WIndows 10 (minimizing restoring etc..) when on 4k res on main monitor? It was pretty bad, after updating bios it got better but still not smooth as it should be, especially if theres a video playing.

Comments

  • Hello samuelaviv,

    May you record a video of the issue?

    Thank you very much.

  • It's pretty hard to see in a video because of frame rate, maybe you can spot a tiny hiccup on restoring the window but to the baked eye it's much more choppy. The choppiness is not uniform, it happens mostly with native win10 apps, and it's just on the main screen on 4k, lower res perform much better.


    Maybe it's unrelated but I also experience constant random crashes of all of the windows native apps that are open at that moment, at least 5 a day.

  • Okay so I made 2 screen recordings so you can see the problem clearly and in comparison to an 1080p monitor, I scroll the steam window and on the external 1080p monitor it scrolls smoothly, and on the Asus zenbook 4k main monitor scrolling is so choppy it hurts and its the same generally in animation in windows. Games work well.

  • Hello samuelaviv,

    What if you set all program to work under the integrated GPU?

    Thank you.

  • You mean in the 3D setting in Nvidia control panel? If so I did that, made the default to the rtx2060 and also changed manually in the programs tab those that could be changed to the rtx2060. Still get the same stutter in windows.

  • Hello samuelaviv,

    No, I mean the opposite.

    Set it to the Intel one.

    May you please try?

    Thank you.

  • Yeah that was the default though, I switched in the first place because it was bad but ill give it a try again.

  • I did a windows reset today, Its all fresh and on default settings, which are to use intel and its the the same jittery stuttery mess.

    Its pretty crazy that a $2500 laptop thats supposed to be the laptop of my dreams from a company like ASUS cant give me the basic performance of smooth animations in windows. My 10 year old 1080p dell screen is displaying windows animations buttery smooth and a 4k brand new premium ASUS laptop monitor cant even get close to that. Not to mention the janky wobly mouse trackpad.

    Ive taken a loan to buy this laptop, ive imported it special from the USA, all that effort and money just to be constantly bummed out every time I scroll a window. IF this doesnt get solved via firmware update or something like that I will 1 star this on amazon, ill never buy an ASUS product again and ill tell anyone who would listen to stay away. Not that ASUS will care, but I will.

  • Hello samuelaviv,

    May I have the BIOS and display driver version you are using now?

    Thank you.

  • samuelavivsamuelaviv Level 1
    edited July 20

    I was on BIOS 307, but I just updated to 308, and I am on the latest Intel DIsplay driver 26.20.100.7372 and the latest Nvidia Graphics driver 451.67.

    I must say, after the update I can see an improvement, when I scroll a page on the browser with a video playing, its smooth now, I checked right before the update and it was Jittery when the video was playing. But, scrolling in steam, is still as displayed in the videos, its very jittery/choppy and when I move the window to a 1080p 60hz monitor, it scrolls super smooth, so there is still something off.

    Btw, when I change resolution on the laptops monitor to 1080p or 2048p its perfectly smooth scrolling everywhere.

    Oh, and I turned off any power optimizations in power options, im on velocity fan profile and I turned on graphic processing in windows:


  • Hello samuelaviv,

    Thank you for the udpate.

  • edited July 23

    Hello @samuelaviv ,

    You were using an external mouse to scroll, right?

    How about using our touchpad? or another external mouse?

    and if you go to IE>Settings>Internet Options>Advanced> Check" Use software rendering instead of GPU rendering"

    would it get better on regular web browser ?

    Thank you.

  • The problem is not the scrolling, the videos display scrolling as an example of the choppiness of the animation in windows in general, I can scroll with a mouse or with the touch pad, thats not it. it also isnt relegated to one app, like IE, and who uses IE anyway, I use edge or chrome, and its not about that, because the choppy behavior is repeated everywhere, the start menu, minimizing and restoring of windows, the steam window scrolling, which by the way is what I scrolled on the videos so I dont know why you would you point to IE or any one app.

    This is clearly not the direction, when I change resolution to be 2048p its night and day, its not just that the scrolling is smooth, everything is silky smooth when not on 4k, moving windows, minimizing, opening start, dragging windows, every single thing in windows is moving normally, On 4k it stuttery everywhere, so a setting in IE wont change anything that has to do with everything i described.

  • Hello @samuelaviv ,

    well....mouse do have something to do with this, may you double check?

    Especially you said lowering the resolution help....

    Also, if you change the setting in IE (or Edge), Chrome will follow.

    Please kindly check as well.

    Thank you.

  • No, mouse most certainly does not have anything to do with this, I have "double" checked, might even say triple and quadruple and quintuple checked, its right there to just scroll, its not like I had to assemble the touchpad, I would imagine that was pretty clear in my answer. The mouse and the touchpad are the same, actually, its slightly worse on the touchpad because of the nature of the continuous motion on the pad.

    I changed in IE to software rendering, that did nothing. And why would it? does that have any bearing on windows animations? I am pretty sure a setting under internet options in IE has absolutely no effect on how windows it self draws windows and animations.

    If it was a debugging or troubleshooting strategy for identifying the issue and to see if on IE itself, as a closed sandbox, it makes a difference in a specific website in which we can replicate the issue and test on/off hardware rendering, thats another matter, but you didnt ask any of that. There is no point in toggling a dead setting in a dead browser in hope it would have any bearing on windows own animations and drawings.

    The issue is system wide, not a web content issue, or a chrome or edge or any of those, its something directly with asus system build, compatibility or something along those lines.

  • Hello @samuelaviv ,

    okay...

    I have send you PM.

    Please kindly check.

Sign In or Register to comment.