Google play won't download/update.

AylaAyla Level 1
edited September 2020 in Fan Chat

Asus Zenfone M2


Hi, it's been a while since my google play won't update/download any app. It keeps showing "waiting for download".

And all other phones/ pcs in the house work/download just fine from google play. What can I do?

Comments

  • XernXern Level 1

    Well the first is best to check whether it's your phone or your internet connection. If your using WiFi, try using your data instead. I this once and it turned out it was my Wifi that was the problem.

  • AmitGardeAmitGarde Level 5
    edited July 2020

    Go to

    Settings>apps&notifications>all apps>right corner 3 dot>reset app preferences

    And see if problem is solved by trying to update any app in playstore

    Thankyou 😊

  • AylaAyla Level 1

    Yes I can download if I'm using my data, but the point is, if I have WiFi connection and I can download and update apps from other phones just fine from it, why can I not do so from my Zenphone? I can't be wasting my paid data like that, what if I need it when I'm not at home? Since I don't have that much paid data and I think it's a bug ;c

    So, I tried it, and it didn't work. Even checked if in the options it was selected the one to just download from mobile date but it was up to every connection, so I don't know what to do anymore.

    I received a software update and was hoping it would fix this but it did not.

    I have 3 types of WiFi connections but none of them lets my Zenphone update/download, but Android and IOS download/update just fine. What more could I do about it?

  • May be its a playstore bug try clearing cache of playstore from settings apps & notifications and than force stop it and than clear data and try relogin of playstore n see it that helps


    Thanks😊

This discussion has been closed.