Asus Rog Phone 2 won't charge from bottom USB C port unless phone is restarted

I am unable to charge my phone from bottom USB C port , unless i restart my phone.

Once phone is restarted while connected to charger it detects charging from bottom USB C port.


But if i unplug and plug in again it is not detected

«1

Comments

  • RAIDEN™RAIDEN™ Level 2

    You seem to have the same issue like mine , so here your bottom port is basically loosened and this is a hardware issue.

    So i d suggest you to go to service centre to get it repaired asap !!

    I got mine few days back where i had the same issue

  • krkaran12krkaran12 Level 1
    edited June 14

    Bottom USB Cworks fine if i reboot the phone without any change

  • ronkpa7ronkpa7 Level 1

    Yes brother same problem happened to me today, so I thought my phone's bottom port has gone bad. Then I checked on forums and Reddit. It's solved for me now after I followed ur advice and restarted the phone while the USB was connected to the bottom port. Also I was able to charge from the side port fine, and disabling battery care seems to work as well, as they said in forums. So, I think it's not a hardware/ faulty port issue but rather its a software issue as I'm able to charge fine now. Have checked with different cables and chargers.😊

  • ronkpa7ronkpa7 Level 1

    It's not a hardware issue bro, definitely not loose port issue.... it's a software issue. I faced it since today morning only now its fine and also the port wasn't wet or anything. Check my reply to the original poster for solutions. It worked for me. Thanx.

  • krkaran12krkaran12 Level 1

    What was the software solution that fixed it.Can someone please post a software solution


    I have tried reset,downgrade to Android 9 ,and a few other options


  • If you have downgraded to A9 and the problem persists, then it would point to hardware where you have a loosen USB C port.

    Your best bet is to go to Service Centre to get this checked that out.

  • krkaran12krkaran12 Level 1

    And i say again,if i connect charger and reboot device the charging works fine.

    It is definitely not a charging issue but an issue with USB configuration in Kernel.

    Being an Android Developer i know the difference between software bug and Hardware issue.

    Seems i won't get solution here,i will debug this issue on my own with kernel logs

  • ronald1985ronald1985 Level 3
    edited June 19

    If you know how kernels work, kernel will contact the USB-C port board, which means something is not initialised when you plug in. When you restart, that extra power boost can initialize the hardware from the motherboard. That's why restarting works.

    To me, it sounds like the USB-C has either become loosen, a defective USB-C port or a short circuit to the USB port (potentially by having a charger that's plugged in and insert it into USB-C port).

    Furthermore, unless your not on the latest firmware, I certainly haven't seen this issue as I use my bottom USB port all the time.

  • krkaran12krkaran12 Level 1

    I have checked all UsB profiles and modules are loaded correctly upon connecting USB C cable.

    I am sure this is not an hardware issue but related to new USB priority implementation by Asus.

  • Does your side port work?

    Was your bottom part working as normal when you brought the phone?

  • Same problem for me..can charged only after phone restarted..also this happens after latest update [200605] ROG Phone II_ZS660KL_JP_17.0240.2004.9

  • krkaran12krkaran12 Level 1

    Yes the side port works fine and the bottom port also works fine after reboot.

    And this issue is faced by many ROG2 user after [200605] ROG Phone II_ZS660KL_JP_17.0240.2004.9 update.


    So clearly this is not a hardware issue


    I will try to get serial logs and check the issue. Probably would need to customize Asus Kernel code to resolve this issue

  • Change cable and/or charger and see if that helps.

  • OPCOPC Level 4

    Charger or cable would give problems on both ports, as in my case. A faulty cable would not work on any port and any phone. I tried mine also on my wife's phone and it stopped charging there as well. So I believe krkaran 12 is right.

  • ronkpa7ronkpa7 Level 1

    Hey bro, chibai! You can see my earlier reply to the original post as Karen has said, it is a software issue cos it happened with me only after the latest FOTA, plus as I said earlier I disabled schedule charging, turned off battery optimization and restarted the phone while plugging in the USB in bottom port. It worked and also I would like to say that now it seems to work most of the time. Only once a day it poses this problem of not charging then if I reboot with cable plugged in its fine and then the while day it seems to charge fine as I randomly tested it throughout the day to see if the problem persists or not. So, i hope they release an update to fix this issue soon.

  • ronkpa7ronkpa7 Level 1

    Thanx bro, most of us are not technically gifted like you😁 so ursolution worked and I just want to add that now the problem is intermittent for me. I dont know why, but once a day it occurs, so I simply do what u suggested and its gone, then the whole day it doesn't occur. I randomly test charged it to check for the past few days. I hope they bring out an update soon.

  • ronkpa7ronkpa7 Level 1

    Hi, we are facing this issue and I almost sent my phone to the service centre but thanx to karan here, the solution of restarting the phone while the cable is plugged in worked. Now, it's a pure software issue as the phone charges fine from the bottom port with the same cable and charger, it works on the side port as well. And all of a sudden this issue started with so many people, I checked Reddit and other forums as well and there too people are looking for a solution. So, except a very few hardware issue cases I dont so many people will have the same issue after the latest update at the same time.... BTW its more like once a day issue for me now, as I restart the phone with cable plugged to the bottom port it works fine the whole day. I test charged it randomly during the day to check and see whether the problem persists or not and it charges fine. Then the next day, or the day after, it causes this issue again and I follow the step given by karan and it works again. So I think they should come up with an update to fix this as it started after the latest update to many people.

  • You should send it to repair centre just to ensure its not a hardware issue, but obviously when it opens. Not all issues can be resolved by software.

    Can you send the link across for the issue on Reddit?

  • @krkaran12 @ronkpa7 @John Pachuau Can you guys help me out with device logs? I'm sending you each a PM with instructions.

  • krkaran12krkaran12 Level 1

    Hi @Gustav_ASUS ,

    I had two fold problem Hardware + Software.

    1. Hardware problem resulted due to splashes of water on Bottom Usb C port. This was resolved by replacing the Bottom USB C port.
    2. Software Problem was due to Charger Type not being set when the charger cable was plugged in while device was ON. This is a typical Kernel Flag issue and after unlocking Device bootloader i was able to tweak the flags.

    I will not recommend software solution to anyone because it will lead to voiding Warranty

    Sorry i won't be able to share my Device's logs , since i have done many customization's and i don't want to share details

Sign In or Register to comment.