How do I fix my internet connection (Wi-Fi) on my ROG Phone 2 that runs on Android 9?

My exact ROG Phone 2 is the one with 120 hz, 12gb, 6000 mAH battery, etc. Also, the physical phone has "Tencent Games" on the back.


1) When I bought this phone, everything works amazing except the Network Connection. Basically, I have enabled the 'Network Speed' on the 'Status bar icon manager'. When idle, the numbers read something like 252 B/s, 88.9 B/s, 325 B/s, & at some point, it crashes & becomes 0 B/s. I don't know why that happens. It will get to 0 B/s every 7-8 seconds.

(You can see the attachments. The screenshots titled 1,2, & 3).


2) When I am downloading something as heavy as say 2.5 GB, it will read 14.2 MB/s which is really good & yes, the download takes 3-4 minutes to complete which is excellent. I think there is a glitch because when I am downloading, the network signal is good but when idling/browsing the signal is really bad.

***(You can see the attachments. The screenshots titled 4).***


3) Now when I do Ping test, look closely what happens. I took screenshot while it was on the download stage, another screenshot when on the upload stage, & last one when both tests were completed. Do you see the pattern? It is only fast when it is either downloading or uploading (under load).

***(You can see the attachments folder. Download it please to view my images as ASUS does not allow me to put photo attachments because I am new to this community or basically a Level 1. The screenshots titled 55, 66, & 77).***



4) When I am browsing on Instagram, sending messages on Messenger or WhatsApp, or looking through chrome, it is slow & unknowingly why it does that. It is also a big trouble when playing games because all of the sudden, I get disconnected.


5) Don't worry. I had a J7 Pro phone before upgrading to ROG Phone II & the with the same network, everything was working fine. I had even tested it on my siblings other phones. There are no problems at all. It's just with this phone (ROG Phone 2). Furthermore, I tried disabling "Wi-Fi Scanning, Bluetooth Scanning, Manually configuring DHCP to static & manually putting IP Address, Gateway, & DNS. I have also tried VPN from other softwares, I have also tried everything I found on google based on my search. THEY ALL DO [NOT] WORK!


I look forward from hearing from all of you guys. Thank you all for your help!

Comments

Sign In or Register to comment.