Asus Rog Phone not charging with original charger

houdeks77houdeks77 Level 1
edited October 2020 in ROG Phone 2

Hi all,

My Rog Phone 2 does not charge with original charger. It shows the hypercharge icon but does not charge. I tried different cable ... no luck. Different charger works fine, original charger when used with different device works as well. It seems to be a sw issue to me.

How to resolve the issue?

Standa

«1

Comments

  • Are you on A10? Is yes, did this happen after you upgraded? Anything that you've done so far on the software side of things? Does the sise port work? More basic information would help remove variables and pin point a possible cause be it software or hardware.

  • It started after last update in Feb, am not on A10, side port is the same. The two thunderbolts and cold not charging phone, it does not matter if phone is on or off. Original cable with different charger is fine. It only happens when I connect original charger.

  • That's odd I don't think there was ever an update for A9 released last February. Anyway the issue might be the charger brick itself.

  • Have your charger or phone been in a cold environment?

    What happens if you restart your phone while the charger is connected?

    Same result on both ports?

    What happens if you have the aerocooler in between?

  • Behavior is consistent, just the icon, no charging as the hyper charge is dead - e.g. the charger does not reach the maximum. No cold weather.

  • Same thing has happened to my phone as of 3 days ago. Can get fast charge to work through both the original and seperate chargers. But cannot get hypercharge to work. Says it is, but is actually discharging. Confirmed with Accubattery app. Safe mode does the same thing. Have tried all the ports (including with and without the fan adapter), restarting multiple times, charging whilst on or off. No matter what, the phone displays the 2 lightning bolts and states in setting that hyper is on, but the phone does not charge. Only thing I have not tried is the factory reset option

  • ok, I will send you both a PM with instructions how to log your device

  • @futcher76 @houdeks77

    You still haven't replied my PM (Private Message)


  • Same issue there with a10.

  • Then please help us solve your issue by replying my PM

  • I got the same problem too.. I'm using samsung charger to charge my phone now but it's not fast

  • FakhryFakhry Level 1

    @maxwilliam.daniel2 yes i face the same problem...

    How about your original charger?

  • Prakhar RaiPrakhar Rai Level 1
    edited May 2020

    Same issue with me also! After the latest update the phone doesn't charge with original charger. Im using Poco x2's charger and it seems to work ok,but its really strange that original charger is so lousy! Please Asus being such a reputed brand and selling such high end products like ROG Phone 2 you guys can't even provide good software support. I don't think I'll even think of buying any future Asus product. Disgusted!

  • I also have the same issue the hypercharge icon is showing but the phone is only charging at 300 to 600 ma but its working fine with a different charger at super charge please help

  • SbudiSbudi Level 1

    Hi, im facing same problem yesterday. hypercharge stuck while charging with both icon and text showing it charge with hypercharge.

    I've clear cache,factory reset even still same problem. then im using standard asus charge 18w it takes bout 12 hours and still at 35%.

    can you send a PM how to log device. Thanks in advance

    *position last stock rom WW (build 60)

  • Hi mods,

    same thing happened to me..on A10 now..it started when my battery got drained, I charged it with original charger but was not charging at all..do you recommend reverting to A9?


    TIA.

  • Hi i'm french ans i've hot the same issu don't remember if i've an update before this problème appear want to know if the issue came from the phone or the charger itself Can you help me?

  • I got same problem i used OnePlus 3 dash cable of previous phone its working fine rog 2 orginal cable was not that good

  • Hi, I am facing this problem now with Asus Rog phone 3 ...please help.


    The other charger is working fine and this charger works with other phone .

This discussion has been closed.