Unlocking the bootloader crashes fingerprint reader

Hi, well, again, this time with another problem. I've unlocked my bootloader using official ASUS tool and since then anything that uses fingerprint crashes (Settings, OneTimeInit). Does anybody know how to restore it's functionality while maintaining bootloader unlocked state? Relocking fixes the problem. I've also tried unlocking without any fingerprints set. Firmware reflashed to both slots. No luck.

Comments

  • I have the same issue getting ready to flash firmware .129 back to phone so I have fingerprint back. I've heard that you have to downgrade to pie then unlock boot and then do the ota but I find no firmware to downgrade to pie.

  • Yeah, me too, on xda :p It worked. Asus dev team should probably look at this issue.

  • ColorSageColorSage Level 3
    edited February 28

    Well, I relocked bootloader rendering my phone unusable because dm-verity fail, then flashed .167 service firmware, updated to .194, unlocked the bootloader then upgraded to Android 10. It works now.

    However to fix this issue you'll only need to:

    1)Downgrade to Pie .194

    2)Unlock the bootloader

    3)Upgrade again to Android 10.

    Unfortunately, afaik Asus doesn't provide any way to re-unlock the bootloader via fastboot which is real pain if you relock and your partitions remain altered in any way. So, be careful. Not-nice brick will happen otherwise.

  • I will check with our devs if this is something we can fix. Thanks for highlighting!

  • We're already developing a new tool that will fix this. No word on when it will be done though

Sign In or Register to comment.