"Camera Cannot Flip" Issue After Calibration

Zoidsfan77Zoidsfan77 Level 1
edited September 2020 in ZenFone 6

Greetings fellows!

I noticed my flip camera was not coming up all the way, maybe 80-90% of vertical. I thought, no big deal, I'll just do a calibration. So I did, and I did it per the on screen directions. Unfortunately, it made the problem much worse. The camera will now never go back in all the way (it still doesn't flip up to vertical).

I have attempted calibration many times, with the same results. "Load defaults" doesn't fix it, or even get it back to the way it was. I should also mention the camera works fine if I operate it manually via the camera app, or hit the retract button (sometimes it takes two attempts).

I suspect this is a software issue with the flip camera calibration feature.

During calibration, the camera seems to stop short of fully flipped and fully retracted. Instead of a 180 degree sweep it is more like 150 degrees.

When flipping the camera in the camera app, it says "Camera Cannot Flip" (it does flip, just not fully).


Anyways, if anybody has a fix for this, please let me know!

If any devs see this, let me know what you need from me in regards to info / logs.


Thanks again!


EDIT: I should also mention that I have tried with, and without a case. I have a screen protector, but the proximity sensor is working as normal.

Comments

  • You can try factory reset if all other options not working....

  • Maybe that would work, but it would not prevent it from happening again. I think this is a software bug.

    Also, I don't really want to factory reset if I can avoid it.

  • EDIT: I should also mention that I have tried with, and without a case. I have a screen protector, but the proximity sensor is working as normal.

    I'd guess, on the contrary, that the cause of the problem will be the screen Protector but you probably do not want to take it off to test it.

  • I have started facing this issue to.. Tried all possible solutions online. Cleared cache, storage, removed protective back cover. But its not working

This discussion has been closed.