cancel
Showing results for 
Search instead for 
Did you mean: 

X670E-Hero can't flash BIOS to earlier version

megazeban
Star I

I updated to  bios version 1709 but have been getting frequent crashes. I try to flashback to 1602 but even with "Bios Flashback" Enabled in the bios, it keeps saying, "This file is older, please enable "Bios Flashback" despite it already being enabled.

 

I also tried to turn the PC off and use the flashback button, it doesn't do the update there either, it will flash for 5 seconds and then remain solid, showing that the update couldn't go through. I have already done a FAT32 format and re-transferred the file to the USB and still no luck. I've never had BIOS update issues prior to this.

3 REPLIES 3

Jiaszzz_ASUS
Moderator
Moderator

Hello, @megazeban 

May I inquire whether you updated to BIOS version 1709 due to hardware changes or for another reason?
After completing the update, did you clear the CMOS?
The content of BIOS version updates may potentially result in an inability to revert to older versions.
Regarding the crashes you're encountering on BIOS version 1709, could you kindly provide the following information to help us better understand your situation?
- Do these crashes occur in specific situations? For example, does it happen after playing a particular game for 10 minutes?
After a crash, are you able to restart immediately, or is there a need to wait for 10 minutes before a restart?
- What manual BIOS settings have been adjusted? Is there still a crashing issue under the default BIOS settings after clearing the CMOS?
- the brand, model name, and part number of the DRAM currently installed
- the brand and model name of the CPU, GPU, SSD/HDD, and PSU currently installed
- the OS version and OS build

Thank you.

Hi, @Jiaszzz_ASUS 

My hardware:

Ryzen7950X3D,

 G.SKILL Trident Z5 Neo RGB Series (AMD Expo) DDR5 RAM 64GB (2x32GB) 6000MT/s CL30-40-40-96 1.40V Desktop Computer Memory UDIMM - Matte Black (F5-6000J3040G32GX2-TZ5NR)

Gigabyte RTX 4090 OC

PU: EVGA 1200 P2 Supernova

Samsung 980 Pro SSD. 

Windows 11 Pro

Version 10.0.22621 Build 22621

I updated as it is a newer platform and in general, I've seen better performance/stability as I've upgraded each bios update.

I did not clear CMOS after the update. 

The crashes seem to occur when the CPU clocks hit a certain frequency. This would largely occur when doing a task that requires more CPU power, i.e. starting up a game, or during intense moments of a game. the reason why I think this is the case is that once I reset to defaults everything seems stable; meaning that the current presets that are available in the bios for the X3D related settings are not compatible with the bios, and I think the guardrails of the new update cause the motherboard to hard reset. Since I reset to defaults and have not loaded the X3D related presets, I haven't had a crash. However, all my cores are now stuck to 4200mhz across the board. I do I have EXPO Tweaked enabled as well.

 

Prior to this, on 1602 I was able to use the X3D Preset on the bios with no crashes whatsoever, so this leads me to believe that the guardrails on the bios are causing the crashing.

 

I hope this is enough information, let me know if I can provide anything else.

 

Hello, @megazeban 

I apologize for the delayed response.
Based on the situation you described, the system operates normally under the default BIOS settings.
Regarding memory overclocking, we recommend starting with the settings from EXPO I.
Please verify that the memory is installed in the DIMM_A2 and B2 slots as per the user manual's recommendation and try installing a single memory module first to ensure overclocking stability, and then proceed to install the second module if possible.


For CPU overclocking parameters, we also suggest starting a threat in the ROG forum's overclocking section (OVERCLOCKING & TWEAKING) for further discussion.

Thank you.