Showing results for 
Search instead for 
Did you mean: 

Trying to reuse old board

Star II

I have an old motherboard (b450m-c) and an Intel quad-port gigabit network card. It is PCIe x4. I have a samsung evo 1TB NVMe drive in the M.2_1 slot. The OS (and it seems the BIOS - I updated to the latest version available, 2021) doesn't see the card. I've tried tweaking settings in BIOS but there is honestly not much to configure. I think the only PCIe options were: Gen1, Gen2, Gen3, and Auto. I've verified the Intel card is good in a different motherboard. I've started looking at a riser card that would connect the other M.2 port to a PCIe x4 expansion slot. Is that the best option or have I missed something with configuring this? Thanks in advance!



Hello, @rla2023 

May I inquire if you are using an ASUS motherboard?
To ensure accurate identification of your specifications, could you please provide the complete motherboard model and the current BIOS version?
Regarding the issue you've described, we recommend referring to the troubleshooting steps outlined in "[Motherboard] Troubleshooting - Cannot find the hard disk drive or SSD (M.2) after motherboard power..." for confirmation of relevant settings.

Thank you.

Hi, thanks for the reply. It is an ASUS motherboard. The model is Prime B450M-C. The BIOS version is the latest available for that model (sorry, I can't recall the exact version number since I'm not right by the computer currently.) I will confirm those settings you mentioned and get back to you. Thanks again.

Hello, @rla2023 

No problem, we look forward to your update.

If you encounter any further difficulties or have any concerns, please feel free DM me anytime.

Thank you.


I've configured bios settings as outlined in that article but the network card was still not working. I've decided to use the motherboard for other purposes and got it working fine. 

Thanks for the help with this.