cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX B350-F won't update BIOS to latest version - Only some of the way??

rfrost16
Star I

I keep receiving the "Selected file is not a proper BIOS!" error, but I know for a fact it is because I already have managed to update the BIOS several times from its initial version to version 5606. When I try to update it to any of the further versions I receive this error. They are the same motherboard bios files from the ASUS website.

Yes my USB is in FAT 32, if it wasn't I would not of been able to update it at all of course. I can't find anything on the forums about only being able to update BIOS some of the way, so most 'typical' reasons for BIOS not updating don't seem applicable.

Please help me, I am absolutely lost and have been pulling my hair out over this, I need to update BIOS to its latest version to receive compatibility for my new Ryzen 5 5600.

3 REPLIES 3

Jiaszzz_ASUS
Moderator
Moderator

Hello, @rfrost16 

May I ask which version you are planning to update to from version 5606, and have you tried using another USB for the update?
Upon confirmation, ROG STRIX B350-F GAMING supports two BIOS update methods: EZ Update and EZ Flash 3.
Therefore,besides cross-testing other USB drivers, we recommend trying the EZ Update for the BIOS update.

Thank you.

I am trying to update it to version 6203, but have tried 6063 and 6042 as well. Initially the BIOS was 0401 and I managed to gradually update it to version 5606 just fine. Any of these further versions just give me "Selected file is not a proper BIOS!". I did this all in one sitting, so did not change anything about how I was doing it or the USB. Since then I have tired again with a different USB, but I am still having the same issue. 

Updating the BIOS via EZ Update is not a great option, because for some reason the OS is very unstable and crashes frequently, so it is a pain to do anything on. I am going to do a reinstall and start fresh, but wanted to replace the CPU first, to do that though I need to update the BIOS. 

Hello, @rfrost16 

This could be due to a large span of BIOS versions.
We suggest that you try updating the BIOS gradually to smaller version increments, starting with 4602, then 5204, 5603, etc., until you reach the latest version 6203.

Thank you.