Calls not received. Texts delayed.

123578

Comments

  • @LP_ASUS Same problem. Calls go to voicemail, no notification. Not always but often. I have Simple Mobile (T-Mobile MVNO).

  • AlDollazAlDollaz Level 1
    edited May 18

    On T-Mobile and having the same issues (see my post in main ZF6 forum). VoLTE and Wi-Fi calling would help.

  • Have you checked your wifi calling settings in the "secret" settings? I haven't had any missed calls or texts in the past weeks since I made sure that was turned off. It may be unrelated but worth a try if you haven't. It doesn't fix the lack of volte and the sometimes poor coverage that sometimes leads to, though.

  • dt808dt808 Level 2

    i finally did the 'secret' settings and turned off wifi calling. we'll see if its helps me or not. i also have another option called 'enhanced 4g lte mode'. are u guys turning that on or off?

    thanks!

  • Give it a few weeks and report back if it helps. Or sooner I guess if it doesn't.

  • dt808dt808 Level 2
    edited May 19

    so after setting up the secret settings i can already report back a noticeable improvement in call quality. i made several calls to people who used to say i sounded distant or they couldn't hear me clearly and they said call quality now is really clear and clean. calls also connect much more quickly and so far text messages haven't gotten stuck in 'sending' status. still too early to see if I'll miss any calls or messages but so far today I've gotten every single call. will report back if anything significant happens but I'm happy right now lol.

  • justinleon2113justinleon2113 Level 1
    edited May 20

    Hello all. Thought I'd just report back to say I'm in an area with coverage again. I reset my phone a few weeks ago due to having a lot of duplicate downloads and old apps, so I thought I'd give an update on my "fresh install" experience.

    In areas I used to have good service, I now experienced poor reception. in addition to the suggestion from @skylerwolfe regarding turning wifi calling off, I also recommend the suggestion by @Bluetooth over here:

    Original Thread: https://zentalk.asus.com/en/discussion/13421/zenfone-6-on-at-t-in-us-anyone-getting-lte

    Changing to Global Auto boosted my bars dramatically and there was no longer a 5-10 second delay when first making a call.

    Also, @dt808 I have Enhanced LTE set to Off since that seemed irrelevant in this current T-Mobile/ASUS relationship.

    I don't really get a lot of texts so I've been testing text responsiveness mainly by getting one-time verification codes from banks or my old Apple ID. Lately they have worked as expected. I will keep everyone posted.

  • dt808dt808 Level 2

    @justinleon2113 - great info! good to know there are other solutions if something i've tried doesn't work. this is my second day with wifi calling off and so far i'm still good so i'm not gonna mess with any other settings just yet. i just got off a long call with someone and not once did they ask me to repeat myself or said they missed what i said. i'll keep posting on my experience here to keep everyone updated.

    thanks all! 😀

  • dt808dt808 Level 2

    just got off a long call with someone who used to always complain she couldnt hear me or my voice would cut in and out (yes it's my mom lol) and this time she didnt complain once. i asked her if i sounded ok and she said yes and not once did she say she couldnt hear me or ask me to repeat myself and she is hard of hearing. i'm pretty convinced the ability to adjust wifi calling is helping and hoping it lasts because as of now i really have no complaints regarding this phone. (except maybe the lack of a quality screen protector but thats not an asus problem lol).

  • Good to know! In the event anyone needs to factory reset Android this should be the best advice for them (with this current circumstance).

  • dt808dt808 Level 2

    so i had to restart my phone last nite and i didnt do the secret code when my phone turned back on so i didnt have the wifi calling options in my menu. well i missed some calls i made to myself today. those calls all went straight to vm. so i entered the secret code and when the wifi calling options appeared in my menu, the settings were the same as i left them before i restarted. this time however i still missed calls! the only way i got it working again was i toggled airplane mode off and on. this is the quickest way i know of to reset all the radios on the phone. after i did that the calls came through.

    so confused now lol.

    the one good thing is call quality is still great so at least the people i talk to on the phone can hear me clearly.

    will keep posting updates.

    Thanks!

  • dt808dt808 Level 2

    so restarted my phone a few times and did the code to see the volte and wifi calling options afterwards, and missed some calls and now call quality is getting bad again. i tried all sorts of combinations to get things to work but in the end i thought to myself i shouldn't have to do this to get decent call quality on a phone right?

    so my question now is - knowing there is a problem with this phone and t-mobile, is asus doing anything to fix it?

  • Is your wifi calling turning itself off after rebooting? I just did it the one time and it seems to stay off. Do you have "enhanced 4G LTE mode" turned on? I ended up turning it off because I figured if there is no voLTE then it wouldn't help and maybe it would mess things up.

  • dt808dt808 Level 2

    any changes i make are still there after rebooting and i've had wifi calling turned off this whole time. i did have 'enhanced 4G LTE mode" turned on though and since yesterday i've turned it off and so far it's been good with the few tests i've done. we'll see how it goes.

    still wondering if asus is gonna fix this though. we shouldnt have to be jumping through all these hoops just to get decent and reliable phone calls and texts.

    Thanks for the help 😀

  • Sure. I wouldn't get your hopes up too high (or at all really). The predecessor to the Zen 6 doesn't have voLTE on T-mobile. This phone has been out for a year and doesn't have it. The Zen 7 is due to be released, apparently, within the next few months. The US is not a priority market for them, it seems. Sad because I love the phone so far other than this.

  • dt808dt808 Level 2

    yup i hear you. i really love this phone too but i really have no choice so I'm already looking at alternatives. there's a lot of great phones out there lol.

  • dt808dt808 Level 2

    oh and if any asus people are still watching or reading this thread, i'm not asking for a new feature. i'm just asking for voice and message quality to be fixed on this phone for t-mobile (or any other carrier for that matter lol).

  • justinleon2113justinleon2113 Level 1
    edited May 27

    Update: I had an issue with missed calls, texts, and voicemails this morning. I only knew because I went to make a call and instantly got all the notifications. The only change I did a few days ago was change to 2G/3G/4G (in Mobile network settings) from Global Auto (in the secret code "4636"). I only did this to see if data speeds would be different, and they seemed to be a little faster. It appears that setting either doesn't stick over reboots or changes if you go in the Call Settings menu. I'm not sure. Regardless, I'd rather get calls than faster data if there had to be a tradeoff. Wifi calling is OFF and hasn't changed. This is getting even more frustrating day by day. 😒

  • dt808dt808 Level 2

    i missed some calls today too and was able to reproduce it because it was multifactor authentication calls so i could login to a secure site. its weird because it worked earlier in the morning with wifi on, then i tried about an hour later from the same site (wifi still on) and my phone did not ring and the calls were not logged. i tried 4 more times from the same site and none of them worked. i then turned off wifi, tried again, and the call came in.

    i'm already looking at new phones so if anyone wants to buy my zenfone 6, make me an offer LOL!

This discussion has been closed.