Zenfone Max Pro M1 Android 10 Developer Version problem

salim.ahamedsalim.ahamed Level 1
edited September 2020 in ZenFone Max Pro Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone Max Pro M1/ ZB601KL
  2. Firmware Version: .424
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: Battery Draining and Massanger Call
  5. APP Name & APP Version (If your issue relates to the app): Facebook Massanger and Battery Draining.

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


The very last update for MaxPro M1 is "Developer Version" of Android 10 Why all people is talks about it as official . Even the official website says it is a Developer version. (Screenshot is Below)

It is actually a Developer Version not official one. And it is worst in battery draining as like as beta version before .

I updated it as like before beta version But all the features are good accept only 2

  • Facebook massanger voice is not passing to the other persion
  • Battery draining so fast as Beta version of android 10
  • It takes 10% of charge in one houre, when i am not using any app.

Is there any way to provide this info to asus team.

I am losing my faith in ASUS. It's been 5 Years Using ASUS Mobile only this one is giving frustration and This one is most favorite also.



  • I have upgraded from .63 to android 10 then downgraded to .63. the cause is the speaker's very low sound output and hanging of a song all of a sudden in music player. Even the call ringtone sound and alarm sound is too low.

  • Max pro m1 with 4gb ram is not still getting 9 why ?

  • Beta/developer version is published for a reason. It's full of bugs. So don't install it then complain. Just report it to the beta program team so that they can fix it. Stop installing it on your daily device and then of cursing Asus like 70yo Grandma.

  • edited May 2020

    well we are not cursing your asus just because of bugs but

    the main reason for that is your asus is fooling the customers

    first they fooled by saying that they will give a STABLE update by Mid May, but what they did is gave a developer update and for that they took 3 months

    and i see some people like you are defending them by saying, its because of covid 19 or because they release beta 2 or developer because most companies does that etc etc

    but the thing is first they fooled customers gor 3 months and gave nothing, beta 1 and beta 2 are all same, they just wasted 3 months

    and now as they have given this developer update, they have a reason to postpone the stable version for another 1 or 2 months

  • Biomatric finger not working

    Eroor 221

  • When I upgraded from beta 1 to beta 2 almost nothing changed. I think my phone is buggy or whatever but when I upgraded to beta 2 wifi calling isn't there the time format still shows capitalized AM. The good things that remained the same is the bass from beta 1 my charging is still the same when charging my phone powered off, about 2 hours using stock charger. When I update my phone it rarely gets changed, like the boot logo etc. The only thing that changed for me is the Build number. I might be lucky and unlucky at the same time.

  • How did you do it. did you loose data? please reply.

  • Manually download .063 from asus website. Place it in internal storage and restart your phone. A notification will pop-up saying new system update detected. Click on it, wait for phone to restart. Once restarted enjoy pie.

  • You are totally wrong, There is nothing to cursing. I just showed them whats the problem that need to solve.

    and must focus to fix of the bug. If take it as curse then it is definitely.

    Cause they must focus on bugs that makes people unhappy. And they promised a stable version but it became unstable.

    on the other hand they Should focus on the battery side. It dose not supports as they say it will long support.

  • salim.ahamedsalim.ahamed Level 1
    edited May 2020

    Bro it got 9 long before. If your FOTA is not working then you must update menualy.

  • I do not believe asus ..no more.. just lost my faith

  • Hi salim.ahamed,

    Thank you for your sharing. Kindly provide the information below so that we could better assist you.

    >Facebook Messenger

    1. Try reinstall the app, does the problem remain the same?

    2. Any other voice calling app will have the same issue? Could you provide more issue detail (frequency, timeline, steps..)?


    1. Does battery drain while using the phone or in sleep mode?

    If while using the phone, does any specific apps drain more battery?

    If in sleep mode, please 1) Charge the phone to 100% before going to bed > remove the charger > Clear all apps in recent app list > turn off screen > the next morning before using the phone, please screenshot the two pages:

    a) Settings > Battery

    b) Settings > Battery > ""Advanced battery usage"" (tap the battery icon to access)

    2. Viewing the whole charging timeline, does it meet the official charging time: 2 hours 42 minutes charge from 0%-100% capacity?

    3. Is there any zone heating up while using/idling?

  • Hi roopmukherjee1995,

    Could you provide me which android 10 version did you upgrade before, WW-17.2017.1911.407 or WW-17.2017.2004.424? What is your model name, ZB601KL or ZB602KL? Also, any issue detail or video is more than appreciated. Thank you.

    hanging of a song all of a sudden in music player

    > What app are you using that has this problem?

    Could you show us a screenshot of the volume level that you feel too low? Do you feel like it is too low compared to WW-16.2017.2004.063?

  • Hi ranjit12345,

    We suggest that you update to WW-17.2017.2004.424. In this version, we've improved the problem of fingerprint cannot be set.

    You may manually download it from our website: https://www.asus.com/supportonly/ZenFone%20Max%20Pro(M1)(ZB602KL)/HelpDesk_BIOS/

    How to update firmware: https://www.asus.com/support/FAQ/1009748/

    Please make sure to back up your data before updating.

    Hi aakibmir419,

    1. What's your current firmware version and the version you're trying to update to? Setting >About Phone>Software information>Build Number


    Have you tried manually updating?


    Please make sure to back up your data before updating.

    Hi siddsarkar,

    If you are asking downgrade guide.


  • Battery draining in idle mode and in night upto 30%. First I thought it was only for my phone have this issue but many people's are facing this issue. I have done calibrating battery. But didn't Worked and i switched off my phone at night and then also 20% off battery draining. What is this problem can't u guys correct this update or are you publishing ur updates Simply without testing. Very bad from ur side each update, ur bugs are increasing by resolving another bug. It's better to check ur updates first. And Give us new update by resolving these issues battery draining and Bad Front cam.

  • adarshshivam1adarshshivam1 Level 1
    edited June 2020

    i am facing battery drain issue as well in my Asus zenfone MaxM1 pro 4gb version, ASUS_X00TD.

    Battery drain is so fast that it drains from 90% to 10% in 2 hours when idle.., and now facing another issue of sudden battery loss from any battery level to 0% and shut down, and after charging and turning it back on it shows that it had that battery level still shut down and need charger.

    Do suggest what to do, i even tweeted and got reply to dm them, but after dming details now no reply again. so either u guys help or i will be losing trust in Asus service care as fast as my battery drainage.

  • Do a battery calibration by doing the steps below.

    1. Discharge your phone fully until it turns itself off.
    2. Turn it on again and let it turn itself off.
    3. Plug your phone into a charger and, without turning it on, let it charge until the on-screen or LED indicator says 100 percent.
    4. Unplug your charger.
    5. Turn your phone on.
  • adarshshivam1adarshshivam1 Level 1
    edited June 2020

    it doesnt full charge to 100% anymore,doesnt go above 99% still will try that.

  • https://zentalk.asus.com/en/discussion/comment/82345#Comment_82345 check this out, basically same thing im facing.

  • Dear friends

    Thank you all for the reply. I have test my MPM1 for the overnight battery testing, yet I didn't encounter the same issue, and the battery lose in Safe Mode for a night is less than 10%.

    Please provide me the info below so that I could better assist you

    1. Did the issue appear after V424 update?

    2. If the "Fingerprint" is turn off, does the situation remain the same?


    3. Enter "Safe Mode" and leave a 80%-100% phone 

    in sleep(idle) mode in a night.

    # How to enter and exit "Safe Mode"


    If the battery works well in "Safe Mode", please check on any disturbance from the installed 3rd party Apps.

    4. If the issue remains the same in "Safe Mode", please try "the Factory Reset" 

    Settings>System>Reset options>Factory data reset

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

    5.  Is there any zone heating up while using/idling? How long does the battery be used? 

This discussion has been closed.