Asus Zenfone Max Pro M2 stuck on asus logo suddenly



  • we have to wait till this lockdown lift, then only we can go to service centre to fix the issue

    now there is nothing by our side but to wait

  • guptapiya17guptapiya17 Level 1
    edited April 2020

    The same problem I am also facing. The phone got switchoff suddenly and now I am trying to on , its getting stuck at Asus logo and if trying to reboot it , it stuck there also. Not moving ahead from asus logo in both conditions. Any suggestion or idea how to factory reset the phone and to get back the phone in working condition.

  • If you can get into the Recovery Menu then you can try to use the option "Install from micro sd". Depending upon your current Firmware version, you may try different version. But if you get any error again, then you have nothing to do.

  • I received two phone calls today and yesterday each. I guess visiting service center, once lockdown over, is the only solution.

    I am thinking that they should share some DIY kind of tutorials so that user can do it at home if flashing ROM is the last resort.

  • since the bootlock is locked,we can't flash ROM by ourself

    And yes service centre is the only solution

  • I too face this same issue on my max pro m2. On 18th of April 2020, I was busy working on web regarding my duty. Unexpectedly phone got shut down automatically. After few minutes ( after charging up battery to full), tried switching ON again. But it didn't boot fully and got stuck on ASUS logo itself for hours together. Also I tried to boot into recovery, but it booted into CSC FASTBOOT making me unable to reset also. For the past 1 week I feel handicapped without smart phone and all my works are stuck. Request ASUS to find a way out at the earliest.

  • But how would the software be flashed if it's in locked state. I think our phone are trash now. I have searched alot, the only solution would be replacing it with a new or maybe replacing it's motherboard. Someone also suggested it previously and I think it's the only solution now.

    No official from Asus has answered to this and I think they will not take any responsibility for this issue.

  • omiomi Level 1
    edited April 2020

    Same problem facing from 23rd April. Tried to flash my phone amount of times but failed because of bootloader locked. I request ASUS technical team to make a solution so that everybody can fix it from home. Service center wouldn't be a solution. It's difficult to wait till over lock down. So please do something as earlier as possible and come up with solution. We need solution and fix it from home. No second option. Thanks.

  • Im having the same problem also. Seems like no solution.

    Asus suck.

  • If Asus can make the device, provide buggy update to us,then definately they might have something to flashed the recovery firmware in the locked state too

    And no official will ever take responsibility, they will just say we are working in to resolve the issue , kindly have patience and that's it

  • whatever we do by ourself to resolve the issue, nothing gonna work as the bootlocker is locked

    and we have no option but to wait till the lockdown lift and then get check the device by the service centre

  • only solution to wait till the lockdown lift and then get check the device by the service centre

  • It's really bad luck for all of us. We need to wait till lockdown lift unfortunately it's keep extending.

    Even I gave my phone to local service center to fix but he couldn't fix it without unlocking bootloader. He suggested to replacing mother board could fix the issue. Mother boards are not shipped at this time. Finally it's a deadlock.

    It's really helpful if Asus technical team could suggest something to fix this.

  • My hometown did not even have any strict lockdown. I can still move around the city. People still wandering the road and wrking as usual, however the road is not as crowded as before the pandemic. Unfortunately, I cant find any asus service centre here. Im trying to flash it on my own, cant do anything tho, the phone usb debug were locked.

  • omiomi Level 1
    edited April 2020

    C'on bro this wouldn't be a solution. what about people from out of India. Solution must have to be on my hand. Yes bootlocker is locked and that is main problem, We need to unlock bootloader and i request asus technical team to help us with this issue.

  • vhkumar10vhkumar10 Level 1
    edited April 2020

    Guyz Im also facing the same problem from april end. Why this is happening???

    Any update about it?

    If this issue occurs for a group of people, it may be from the company side. This may caused by some kind of timeouts added in the firmware by Asus to make the customer visit to the service.

    And guyz it is happening after the warranty end for the customers who bought that in flash sale

  • sadashivsadashiv Level 1

    Hi, In our case, downgrading also not possible due to recovery mode is not functioning. Only we have CSC fastboot mode and

    fastboot oem device-info command shows Device unlocked: false always.

    Tech team, please suggest any other solution to fix this?

    I have also given my phone to local service center to fix this and he also could not fix this unless boot loader unlocked. He suggested to replace motherboard could fix this. It would cost around 5000 - 6000 Rs. But at this lock down time no one is shipping motherboards.

    Asus support team really useless and in future I will never buy any Asus products for sure.

    Fyi, Some one posted this to create awareness:

  • Facing the same issue for the past 10 days, don't know how log have to live without my phone. Never gonna buy any Asus product.

This discussion has been closed.