X Mode not locking to 2.96 since A11



  • SwarajSwaraj Level 3

    Still no response from mods over this issue.

    .211 was rolled out but then cancelled due to poor QA and another update .213 was rolled which again didnt fix the main issue. So we dont have any official updates from dec (.190)

    the .211 was already rolled out during chinese new year and it was late to be discarded thats why its still in release notes.

  • VolodesiVolodesi Level 3
    edited March 24

    "Improved the thermal experience when playing the Games."


    Still isn't locking CPU to core clocks I set them to and it's causing my games/emulators to run like garbage. My crappy Pixel 2 XL can run games smoother at the moment. Which is mind boggling.

    Playing a game that is locked to 30 FPS and it lags and stutters like mad cause the core clocks are stuck at 826 MHz still.

    This is the most demanding part of this game and moving the camera feels awful and all over the place in terms of smoothness. I play this game on PC and on my Pixel 2XL and it does not feel this bad when playing on those devices.

    I usually try to keep myself levelheaded about these kinds of issues in hopes it will be fixed. But it's been so many updates and it's never gotten any better. I feel like each update is just crippling the phone more.

    Looking forward to getting a new phone after April. At least I know what brand I am not going with again.

    Edit: Also, glad to see Netflix is still reinstalling itself after the 215 update and reinstalling itself again if you restart the phone.

  • Same issue Rog5 users also..210After update 226.229 firmware version locked only 835mhz only some it goes 1.42ghz. Before locked at 2.48 or 2.84ghz dynamic profile no use in armory crate same advance ,xmode and xmode+(with aeroactive cooler) The problem start up with december2021 still not developer find a proper solution for this type of issue. Thank you for bug update Asus users

This discussion has been closed.