Fast charging not working and stuck at certain battery percentage while charging.

Solid SnakeSolid Snake Level 1
edited February 17 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ASUS ROG 5s Pro
  2. Firmware Version: 18.1220.2112.175
  3. Rooted or not: Not rooted.
  4. Frequency of Occurrence: 3 days in a row.
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


So I've been using my ROG 5s Pro for a month now after I purchased it last December 2021. First few weeks is good in overall performance. My battery charging routine when I 1st get my phone is if it hit 30% battery mark, I charged it till 100%. 20-30 mins tops till fully charged. But this week starting January 12 till today, I've been experiencing slow charging but it shows FAST CHARGING LOGO in my screen and it certainly stuck in certain battery percentage like, 61%, 77%, 89%. I also tried recalibrating my battery. Using it till it shut down on his own. Charging it from 0% to 100%(switch off) then turning it on after getting 100% in switch off charging. Still not fixed the fast charging issue and still stuck in certain battery percentage while charging in switch on. Anyone expriencing it in 5s Pro Models ?


This discussion has been closed.