GPS inaccuracy since beginning of May?

biciklantobiciklanto Level 1
edited September 2021 in ZenFone 7 Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone 7
  2. Firmware Version:
  3. Rooted or not: No
  4. Frequency of Occurrence: Frequent
  5. APP Name & APP Version (If your issue relates to the app): Google Maps, GPSTest, Strava

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Since roughly the beginning of May, seemingly after a device update, I've had issues with GPS precision and accuracy. In the past, I was thrilled with how well the phone handled challenging circumstances, including Strava activity tracking through deep slot canyons (with strong track matching in both directions).

Now, I have major issues with tracking, which also extends to activities like using navigation in Google Maps: it sometimes hangs at an intersection and then I don't know how to proceed, being well past it. GPSTest will also show that it can't get a lock on location despite sattelites being all over the place.

Has anyone else experienced this? Thanks!

(here is a screenshot showing a failed Strava track as I walked down that street. You see that the track line jumps up and down and back and forth, when it should have just been a single, clean line to the right of the street.)



  • Estou com o mesmo problema. Aconteceu após a atualização de hoje

  • That's interesting to hear that it's happening to you too. What version are you running now?

    It seems that someone else also mentioned the issue on XDA a few weeks ago. I apparently am too new to post links, but it's a thread called "Bad GPS signal with Zenfone 7" from user Meuro986.

  • Anders_ASUSAnders_ASUS Level 6
    edited June 2021

    This is not a know issue

    1. First you should factory reset your phone without restoring a backup file. You may still backup your images, SMS and so on but don't restore any backup file.
    2. If it's still not working, then downgrade to A10.
      1. If it's still not working, then send in for repair.
      2. if it works with A10, then upgrade to A11 again and check if it's working.
        1. if it works after A11, then install all your apps
        2. if it stopped working with A11, then please let me know and we will try to find out why

  • Hi Anders,

    Thanks for the reply. I did a factory reset and had the impression it was okay again, but that turns out not to be the case.

    How do I downgrade to A10? Happy to check that next. Cheers!

  • Hello,

    I have exactly the same problems with my Zenfone 7. The GPS issues started in early May. I have factory reset the phone three times since mid-June. The GPS works perfectly after the factory reset, but the problems come back after a week or so.

    Is there any fix on its way for this issue? If not, what can I do? Downgrade to A10?


  • edited July 2021

    I have GPS issues since a couple of weeks, sometime it keeps jumping a few hundred meters, making it impossible to use Pokémon Go properly when walking to and from work...

    Yesterday it counted 3.6 Km for a single 1.4 Km trip between my work and home, it goes back and forth a few times, it makes no sense at all.

    It even causes Philips Hue app to shut off every lights when I'm at home sometimes because it thinks I left home...

    I won't reset my phone or downgrade, this should not be a solution for a software issue.

    As I'm also having background apps not updating as stated in the notifications thread, I guess it's already time to look for a new phone, from a different brand again. I usually switch phones every two years, this one did not even last one year because of all this software issues.

  • lcudstlcudst Level 1

    I've used GPS with maps for 5 days in a foreign city and I faced same problems, I managed it, but it's a bug to be fixed absolutely because it's unacceptable to have a so inaccurate signal. Unreliable.

  • This is just unbelievable, how can GPS be so broken and ASUS just ignore their users...

    Today I was walking back from work, usual 1.4 Km trip, and while playing Pokémon Go the GPS went crazy and kept jumping...

    On my Google Maps trips it shows the same jumps as in the video, and it says I walked 2 Km...

    As you can see, the darker trips were earlier today, it jumped quite a bit too...

    Note : even without playing my trips are jumping around sometimes, so it's not the game causing issues...

  • I noticed the same thing while walking ..somehow this is only happening while walking for me. With the car all seems good! Don't know what yo believe

  • Hi,

    I searced a little bit, and found this (hope you have the WW Version). For downgrade i found this on the Asus Website. This can be found, when you scroll down to the date 2021/03/26

    Source: i cant post links (its very annoying), therefore you have to search in google for "Asus Zenfone 7 update". Then you will find the changelog for the zenfone series 7. There you can find this downgrade information

    ZenFone 7 / ZenFone 7 Pro (ZS670KS / ZS671KS) Software downgrade from Android 11 to target Image Version: WW- (Android 10) for WW SKU only.

    ※ Before you start the downgrade, please make sure all pictures, important data finished the backup.

    The downgrade process will erase all data to be a new system. ASUS company would not not be responsible for the risk of data loss.

    Steps of Update:

    1. Download the firmware to internal storage.

    2. Remove Google Account.

    3. Pull down the quick setting list.

    4. The system will pop up a message which detected a firmware update info.

    5. Execute the downgrade firmware file.

    * If you skip step 5, and you don't know how to trigger the downgrade process again. Please reboot the system, and the downgrade info will pop up again.

    Hope it helps

  • I don't want to downgrade, I want them to fix their phone's software, it's not even one year old and they already moved to Zenfone 8...

    If downgrading is a solution, better switch to another phone with better software and support if it's to start from scratch again.

    Between this and the native apps not working anymore in the background (see the notifications thread), I'm seriously planning to switch in a couple of months if nothing is done by ASUS.

    I loved the phone and loved the fact that it does not have a notch or camera hole, but since these issues and the fact that ASUS does nothing, I'm considering avoiding ASUS phones in the future.

  • TestUserTestUser Level 1
    edited July 2021

    I understand this, I only wanted to provide a workaround, since Asus does not provide any update to fix the issue.

    Downgrading, and upgrading again was written by Anders_Asus and stated as possible solution.

  • Downgrade and upgrade back fixes NOTHING. When I started to notice the notifications issue on A11 I reset my phone to factory at least 4 times and one time I downgraded to 10 and then upgraded back to 11. The issue was still forward to a week ago, I had to use gps to walk to certain address....I can only say it took me 10 minutes to figure out in which direction to go since the gps was either jumping around or was looking as I was not moving at all. I restarted google maps at least 10 times until it started to function a little better so I could know where to head to from my experience downgrading and upgrading back does not work...

    What it is strange is that I only noticed gps issues while car it was working just fine. I have no clue what it is going on( it is good I don't use that often while walking...)

    What it works is downgrade to A10 and remain there...I had 0 issues with A10.... The problem is that I always want latest and greatest version ....

  • Hi,

    I also have a gps issue while driving and it's super annoying.

    It used to be flawless when i bought this zenfone 7 in october 2020.

    I don't honestly remember since when it started to bugs but it's been some weeks.

    Whenever i use google maps or waze while driving, it loses signal after a few moment. I tried to close and restart the gps many times without success.

    I have tried to wipe my phone but there's no improvement at all.

    ASUS Team we need answers please. What should we do?!

    Best regards,


  • I don't know if that would help but if I were in such issues I'd try some GPS Test app which would "reset" GPS stuff, download correct AGPS data etc, I don't understand this area that well but I used to do that in the past on different phones, you can also use such apps to see sattelites visibility, GPS signal strength etc...if nothing you would at least have evidence for ASUS's devs that signal was fine ;)

    I assume that you all have high accuracy set for positioning system, if not, switch it to this mode

    I had issues with gmaps in the past on other phone/s and it was isolated to only a few apps, other were working fine and it was because of Google Play Services package (some versions were fine, some were causing issues you described) so if you somehow updated that package (sideloading etc) I'd downgrade it to "factory version" by uninstalling its updates and while you're there, disable battery optimizations for this package, for Google Services Framework and Android system, I did that for bunch of apps (also system apps as you can see) and I don't have any issues with GPS...I did that to get rid off missing notifications which somehow partially works

    it all seems to me that ASUS fights with battery optimizations and many apps/processes gets affected by that and never/rarely ever wakes up and because of that we are facing different kind of issues

  • I have tried your method and have done so many tests but it doesn't work.

    I still lose the gps signal with maps and waze.

    It is hopeless, this phone is such a mess and asus doesn't give a damn about it.

    Thanks anyway.

This discussion has been closed.