Hopefully finally solved the "Sleep" - "Never Wake up" - problem

S0SS0S Level 1
edited May 2021 in VivoBook
  • ASUS VivoBook Pro X580VD
  • Windows Home 10.0.18362 : 190318-1202
  • Bios: 317


Well over a year ago, my Asus VivoBook Pro starting having an issue of often never Waking up completely after being put to Sleep. On trying to Wake up, the keyboard would light up, but the log-in screen would never appear. This meant a hard shut down (long press on the power button) would have to be done. This has been an extremely irritating time-wasting problem. PDF files, document files, text files, and other programs, along with 2 Browser programs with over a hundred browser tabs, would have to be restarted and restored.

Sadly, no proper fix has been found from Asus tech help even after so many online complaints.

I noticed this issue would only happen when the laptop was in Sleep state for some time, over half an hour, and the issue never happened if the Sleep time was short - less than 15 minutes.

Most dangerous would be an occasional "Overheating while on sleep" - some time (usually within half an hour) after the laptop was put to sleep, it would get extremely hot - until the battery drained. Aside from possible damage to the laptop, it could even have led to a fire.

The FAQ from ASUS is: [Notebook] Troubleshooting - Laptop does not wake from Sleep or Hibernate mode [ https://www.asus.com/us/support/FAQ/1042630/ ] - Last Update : 2020/10/23 10:32

This is a problematic FAQ for this particular problem.

The option 4 is bad: 4. Troubleshooting through Windows Power Troubleshooter

It auto changes screen brightness and sleep timeout settings back to defaults without even asking.

And the option 5 is not the "right" way to fix the problem - 5. Reset the system

When the issue first started, and for some months after that, I kept trying to search for an answer, and never found one that worked. I put up with this issue all this time, but finally got fed up after almost two years of frustration, and finally decided to fix the problem once and for all.

I was led to my solution from a tenforums posting by "joeandmarg0": ASUS Laptop Won't Wake from Sleep Mode [ http://www.tenforums.com/general-support/151674-asus-laptop-wont-wake-sleep-mode.html ]

From an Elevated command prompt, I typed: powercfg /sleepstudy

The resulting HTML "sleepstudy-report.html" gave me a clue:

It showed that when my computer wouldn't wake from sleep - it had gone from Sleep to Hibernation.

Sleeping3   0   Button or Lid   2

I then typed this command in an elevated Command Prompt window: powercfg /SYSTEMSLEEPDIAGNOSTICS

This produced the file: system-sleep-diagnostics.html

It showed an entry where state "Sleeping3" was reached by the reason of "Button or Lid"

But was followed 20 minutes later by: "Hibernate" by the reason of "Hibernate from Sleep - Fixed Timeout"

It was in this Hibernate state for "Duration" 10 minutes!

And after this was when the Laptop "would not wake-up from sleep"

But I knew that I never ever wanted my laptop to Hibernate, EVER, and I had been very careful that it would only ever go to "sleep."

So I looked in my Power Options - Change Plan Settings - Change Advanced Power settings (Control Panel\All Control Panel Items\Power Options\Edit Plan Settings)- and found that somehow my chosen power plan settings had got an option changed to something I thought had never done myself:

When I Expanded: +Sleep >>

Sleep >> Hibernate after >> On battery

 This had changed to : After 180 minutes

I changed it back to: Never

I also went to check if somehow I had enabled Hibernate, at Power Options (Control Panel\All Control Panel Items\Power Options) I clicked on: Chose what the Power Buttons Do (Control Panel\All Control Panel Items\Power Options\System Settings) and then on: Change settings that are currently unavailable - this opens up an area at the bottom that has:

  • Turn on fast startup (recommended)
  • Sleep
  • Hibernate
  • Lock

The settings were as I had chosen when I first set up the laptop - Hibernate was unticked, the other 3 were ticked.

Later I read this: ASUS ZenBook won’t get out of sleep mode [ https://jolandn.medium.com/asus-zenbook-wont-get-out-of-sleep-mode-ux430uar-f298cc9df5aa ] - which seems to also point out that it is a Hibernate issue - the Power option had been somehow modified to Hibernate after 3 hours - but perhaps the hibernation did not happen properly.

I also went into the Device Manager, ticked "Show hidden devices" under the View option, and then checked the Properties (ALT Enter), and for any Devices that had a Power Management tab, I un-ticked every one (they were all enabled) - that had: "Allow the computer to turn off this device to save power"

I went through each and every entry and these were the ones I changed:

Under: Universal Serial Bus Controllers

  • Intel USB 3.0 eXtensible Host Controller
  • USB Root Hub (USB 3.0)

Under: System Devices

  • Intel(R) Management Engine Interface
  • Intel(R) Serial IO I2C Host Controller - A160
  • Intel(R) Serial IO I2C Host Controller - A161
  • Intel(R) Serial IO SPI Host Controller - A129
  • Intel(R) Serial IO UART Host Controller - A127

Under: Network Adaptors

  • Intel(R) Dual Band Wireless-AC 8265
  • Microsoft Wi-Fi Direct Virtual Adapter
  • Microsoft Wi-Fi Direct Virtual Adapter #3
  • Realtek PCIe GBE Family Controller

Under: Human Interface Devices

  • I2C HID Device

Since doing that, I have not had the "Not Waking from Sleep" problem again on my Asus.

I would imagine it is the "Hibernation" issue - perhaps when Sleep is enabled [Power Options (Control Panel\All Control Panel Items\Power Options)], but Hibernate is not - and then a setting in the Advanced Power Settings allows the laptop to go into Hibernate.

If this is the problem, or if it is an "Allow the computer to turn off this device to save power" issue, then it should be easy to resolve.

I hope the Asus tech team will be able to find exactly which one of the above is causing the problem, and fix the issue.


This discussion has been closed.