Camera cannot flip GENERAL ISSUE

Gentlemen, it's been clearly noticed by several users that there's an issue with your phones main feature. The flip camera.
There are several users that have been faced with a camera that won't flip. No matter what model, firmware version, app, it won't flip. The only feedback it gives is the image on whatever software is trying to flip the camera flips, and we get an android system notification with the message 'cannot flip' (example below). This has happened to me since the first time I tried flipping the camera. Only then it happened intermittently. Now I've been 5 days with a camera that won't flip. Even got a firmware update during those 5 days. To no avail. 
There are several threads on this issue and only one has any sort of apparent looking into it via a log file. 
Nothing tangible from you. 
I really want to defend your phone and it you're not making it easy which is disappointing for a 21 year long recurring customer.
I'm available for anything you might need from me as far as debugging goes. If you want me to run this with ADB and some tool I will. I just want to help you guys fix your ( my) phone.
Zero feedback is downright disrespectful towards us. 
So start by properly letting us what the issue is, because at this point either your devs did ZERO looking into it or you already know but haven't found a solution. Which I'm fine with for now. But just man up, be accountable and give us the chance to respect you for that.

«1

Comments

  • Hi
    Does it never flip? 

    If you are using any type of cover/bumper/case, could you try removing it and see if it then will flip? A user has suggested this may be the culprit - and if we can reproduce it more reliably.
  • It's worked with and without the current cover I have and I removed several times in the past few days to no avail. 
  • Yeah, there is like 2-4% chance that it wouldn't flip without clear reason. It happened 0 times under first two weeks/.167 FW but since then (or next updates) it is a thing. For me it usually works after 2nd tap on button however I can't give any info about reproducing a bug due to rare errors. It also happened to me a few times when in Pro mode switching back to rear is being slow (like using manual adjustment). So, I can somehow confirm this bug report.
  • I can confirm. This issue actually becomes a lot more common than 2-4% when you try to flip it out as soon as you retract it. (Quick flipping). Sometimes the camera flips and yet gives the message "camera cannot flip" and a few times (rarely) it just doesn't flip
  • I can confirm. This issue actually becomes a lot more common than 2-4% when you try to flip it out as soon as you retract it. (Quick flipping). Sometimes the camera flips and yet gives the message "camera cannot flip" and a few times (rarely) it just doesn't flip
    It's still a mechanical movement, expecting it to "turn around" instantly after having first moved one way, is not something this mechanism can handle. However we are more interested in the general cases where a single press causes "Cant flip".
  • CH_ASUS said:
    I can confirm. This issue actually becomes a lot more common than 2-4% when you try to flip it out as soon as you retract it. (Quick flipping). Sometimes the camera flips and yet gives the message "camera cannot flip" and a few times (rarely) it just doesn't flip
    It's still a mechanical movement, expecting it to "turn around" instantly after having first moved one way, is not something this mechanism can handle. However we are more interested in the general cases where a single press causes "Cant flip".
    Which is my case. Any isolated tap does not work.
    Makes perfect sense not to buffer and to have a bit of a grace period not to instantly flip back cause its easy to double tap by accident. 
  • Can you check if your proximity sensor is blocked in any way? Or dirty? Blocked proximity sensor will trigger a camera motion stop.
  • For clarity, do you mean the little orifice on the top side of the phone, to the right of the camera module?
    And if so  could you please describe a way to clean it safely.

    Thanks 
  • For clarity, do you mean the little orifice on the top side of the phone, to the right of the camera module?
    And if so  could you please describe a way to clean it safely.

    Thanks 
    Hi ,
    No, I think the hole you are referring to is the microphone hole.
    The proximity sensor is here. You can clean it with a microfibre cloth but generally it should be fine in normal uses.
    We've seen cases where 3rd party cases/covers/etc, covers that up slightly and causes issues. 

  • sousaepedrosousaepedro Level 1
    edited August 2019
    Gotcha, so I cleaned it up and it persists. Sensor was detecting good to begin with.
    I tested with a call and it toggles the screen off when I move my hand over it, and if I put my hand there beforehand and dial it immediately toggled the screen off.
    Sensor wise we're good. 
    The 2 phone cases I've had so far are open on the top so there's no chance  to cover that area.
    Any other suggestions, I'm at your disposal 
  • I'll check with our devs if there are any ways we can test first - without you needing to go to our service center.
    So from this thread, I am under the understanding that;
    1. You do not have any covers on, or screen protectors with dust etc.
    2. Proximity sensor works for example during calls (covering it turns screen off).
    3. Camera never flips , when using Asus Camera app - or any other Camera App (such as Facebook Messenger, WhatsApp, etc).

    Many thanks

  • The point 3 isnt correct in my case. As I mentioned in the post above
  • The point 3 isnt correct in my case. As I mentioned in the post above
    Okay, I'm trying to find your problem description but so far here are the problem descriptions I can find;
    "This has happened to me since the first time I tried flipping the camera. Only then it happened intermittently. Now I've been 5 days with a camera that won't flip. Even got a firmware update during those 5 days. To no avail. "

    "It's worked with and without the current cover I have and I removed several times in the past few days to no avail. "

    "Which is my case. Any isolated tap does not work. "

    I cant really deduce from this ,if your flipping mechanism never works, or works occasionally, or works most of the time but sometimes doesnt? Can you please help clarify?
  • sousaepedrosousaepedro Level 1
    edited August 2019
    CH_ASUS said:
    The point 3 isnt correct in my case. As I mentioned in the post above
    Okay, I'm trying to find your problem description but so far here are the problem descriptions I can find;
    "This has happened to me since the first time I tried flipping the camera. Only then it happened intermittently. Now I've been 5 days with a camera that won't flip. Even got a firmware update during those 5 days. To no avail. "

    "It's worked with and without the current cover I have and I removed several times in the past few days to no avail. "

    "Which is my case. Any isolated tap does not work. "

    I cant really deduce from this ,if your flipping mechanism never works, or works occasionally, or works most of the time but sometimes doesnt? Can you please help clarify?
    The  person you're replying to right now is not the original poster of this thread. That would be me.
    He came in here and described his specific behavior.
    For me it would on occasion completely stop working for a few hours until eventually it completely stopped working. 
  • CH_ASUSCH_ASUS mod
    edited August 2019
    CH_ASUS said:
    The point 3 isnt correct in my case. As I mentioned in the post above
    Okay, I'm trying to find your problem description but so far here are the problem descriptions I can find;
    "This has happened to me since the first time I tried flipping the camera. Only then it happened intermittently. Now I've been 5 days with a camera that won't flip. Even got a firmware update during those 5 days. To no avail. "

    "It's worked with and without the current cover I have and I removed several times in the past few days to no avail. "

    "Which is my case. Any isolated tap does not work. "

    I cant really deduce from this ,if your flipping mechanism never works, or works occasionally, or works most of the time but sometimes doesnt? Can you please help clarify?
    The  person you're replying to right now is not the original poster of this thread. That would be me.
    He came in here and described his specific behavior.
    For me it would on occasion completely stop working for a few hours until eventually it completely stopped working. 
    Ooops! Yes you are correct. Got it - thanks - passing back all the relevant information.
  • I wouldn't describe my situation as an "issue" per se, it's more like the teeny weeny instabilities that a fresh mechanism always has. For me the camera works fine 99% of the times. Out of those 99%, sometimes the camera does flip up in it's full glory, but it still pops up a message saying camera cannot flip. Irrespective of cover or no cover. The 1% times that it doesn't, it's a mixture of camera just failing to flip, or flipping partially (Stressing it's just 1%). Digging even deeper for the purpose of providing detail, sometimes when the camera doesn't flip, only sometimes, the image gets vertically or laterally inverted.

    In my opinion these are just some little mistakes that a new mechanism is allowed to make. 
  • I wouldn't describe my situation as an "issue" per se, it's more like the teeny weeny instabilities that a fresh mechanism always has. For me the camera works fine 99% of the times. Out of those 99%, sometimes the camera does flip up in it's full glory, but it still pops up a message saying camera cannot flip. Irrespective of cover or no cover. The 1% times that it doesn't, it's a mixture of camera just failing to flip, or flipping partially (Stressing it's just 1%). Digging even deeper for the purpose of providing detail, sometimes when the camera doesn't flip, only sometimes, the image gets vertically or laterally inverted.

    In my opinion these are just some little mistakes that a new mechanism is allowed to make. 
    Got it! Thanks for clarification. Sometimes the flipping mechanism will behave with some.. temper I guess.  
  • CH_ASUS said:
    The point 3 isnt correct in my case. As I mentioned in the post above
    Okay, I'm trying to find your problem description but so far here are the problem descriptions I can find;
    "This has happened to me since the first time I tried flipping the camera. Only then it happened intermittently. Now I've been 5 days with a camera that won't flip. Even got a firmware update during those 5 days. To no avail. "

    "It's worked with and without the current cover I have and I removed several times in the past few days to no avail. "

    "Which is my case. Any isolated tap does not work. "

    I cant really deduce from this ,if your flipping mechanism never works, or works occasionally, or works most of the time but sometimes doesnt? Can you please help clarify?
    The  person you're replying to right now is not the original poster of this thread. That would be me.
    He came in here and described his specific behavior.
    For me it would on occasion completely stop working for a few hours until eventually it completely stopped working. 
    After passing the relevant information back, the only conclusion we have at this moment is that there may be a hardware failure causing it to never flip - seeing as it never works for you. As such, we would have to recommend you to contact your local ASUS customer service for a RMA case.
  • Gotcha ?
    Could you refer one to me, please?
    I'm in Lisbon, Portugal 
  • Gotcha ?
    Could you refer one to me, please?
    I'm in Lisbon, Portugal 
    Please see here, for contact information to the Portuguese service team.
    https://www.asus.com/pt/support/CallUs
Sign In or Register to comment.