New feature, bug or...

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone 9
  2. Firmware Version: 32.2050.2050.34
  3. Rooted or not:no
  4. Frequency of Occurrence: non stop
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Hi. Since this morning, the icon for localization in the status bar stays on constantly. Before that it used to appear only when some program was using the gps to set my location(maps, weather, s.o.). No new programs installed, killed all programs which might be using location, except Google(because I can't) and it keeps staying on. Also an update came, but it's the same. I have 3 programs that are allowed to use location, and only they appear in the list of apps that have used location recently.

Is this a new, unwanted feature, a bug, or something suspicious is happening? The battery doesn't seem affected, so I guess the icon stays on, because location is on. But what's the point to see it, while nothing uses location, and how to know if an app updates location, if the icon is always on?

Comments

  • Just removed the chrome and brave permissions, and problem fixed. Tried to restore their permissions to see which one was the cause, but the problem didn't replicate... So for now it's ok

  • b.preslavskib.preslavski Level 1
    edited November 18

    For my great disappointment, it seems the disappearance of the icon was a coincidence. This morning it is on again. Chrome is disabled, brave should ask for location(i suspected these two). And nothing removes it this time, except stopping location.

    Edit - changed this time the stock weather permission for location and icon disappeared.

    The worse is, the phone had a "random restart", like from the other topic, while charging during the night.

  • daniventudaniventu Level 1
    edited November 18

    Was looking for someone with the same issue but could not find a dedicated issue since the object is very cryptic.

    I'm experiencing the same issue and cannot remove the location icon in any way except by turning localization off.

  • Hey @b.preslavski & @daniventu

    I have reported the issue related to the location icon to the R&D team. I'll get back to you as soon as I hear from them.

  • Try changing the permissions for the always allowed apps. Yesterday it worked with browsers, today with the weather stock app, tomorrow we'll see :)

  • Yeah, problem is that the few apps having persistente access to the location would not function properly if I disabled it.

    Which app/system apps did you notice requested your location?

  • I had only Google, stock weather, another weather app and brave browser allowed all the time. Stopping these apps didn't work. Yesterday I put the browser to "ask", today I removed the stock weather to not have access(but it somehow gets location). This did the thing. I'm waiting for tomorrow...

  • I have exactly the same problem since yesterday. Only weather and Google apps have permanent access. Revoking permissions doesn't change anything. Displaying the icon does not affect the battery discharge rate, or it affects imperceptibly. The GPS module is also not active - after starting the GPS Test application, some time passes before the position is determined.

  • Since yesterday, I am experiencing exactly the same behavior on my Zenfone 9 as well (firmware WW_32.2050.2050.34). The localization icon in the status bar stays on constantly, even though I have revoked permisson for permanent access for all apps. Only the system apps whose permission cannot be revoked still have access to localization.

    Completely disabling localization service and re-enabling it again temporarily solves the issue. However, after 10 minutes or so, the localization icon comes back, even without touching the phone at all (i.e. phone in standby, not opening any apps).

    I can confirm that it does not noticeably affect battery life, but it still feels suspiciously like some app is spying on my location.

  • It started showing up for me after the last update, i.e. on version WW_32.2050.2050.34, I turned off the icon in the status bar, but I don't like this solution very much, because then I don't have control over which application and when it uses the location service.

  • I have noticed that users in the Zenfone 8 forum section are experiencing the same issue. 

    Thanks to the hint given by @Rokcy98 I have disabled automatic switch to "night light" and "dark theme" and the issue seems to be solved for now.

    Before, I had it scheduled to "turn on from sunset to sunrise" which seems to cause the activation of the location service icon.

  • I tried this procedure and the GPS icon still shows up. At least this solution didn't help for me.

  • I'm always in dark mode and don't use night light.

    The thing that worked for me was, as I said, disabling chrome browser and the stock weather app - use location only when I use the app(same goes for maps and others) + don't use precise location. However, it still gets the location automatically and the location icon stays a little bit longer, than before. Only a third party weather app and Google can use location all the time. Since this, I have "solved" the problem.

  • Hey everyone!

    The R&D team is currently working to resolve this issue. For now, there is a temporary fix that you all can try by uninstalling Google play service updates.

    Uninstall Google play service via Setting>apps and notification> see all apps>tap more option>show system>google play service>tap more option>uninstall updates.

    After uninstalling updates you need to reboot the phone. This should make the GPS icon disappear.

  • Don't buy Asus. Asus is regrettable.

  • anodanod Level 1

    My weather app always showed the location icon. After changing the permission for the app location to "Allow only while using the app" the icon no longer appears.


  • I just tried your suggestion but the localization icon is still there.

Sign In or Register to comment.