My Rog Phone 5s doesn't launch anymore

HappinkHappink Level 1
edited April 17 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: Asus Rog Phone 5s 16GB/256GO
  2. Firmware Version: updated
  3. Rooted or not: not
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

It happens a few hours ago, i was eating then all of a sudden my phone went off. At first i thought it had just gone into sleep mode so i tried to wake it up but nothing happened. I then thought that the problem could be the battery, so i plugged the cable like usual when i want to recharge it, but, as you might expected, it didn't change anything. Its not booting, I can't even see at which percent of charge it is

I decided to leave my phone 1 hour alone while it was charging, and i used this time for searching solutions on internet. Some said to hold button for at least 15 seconds, so i tried when an hours has passed, but nothing at all. I forgot to specify that it never vibrated during all these tries

So if someone know what the problem is, or how i can resolve it i will be very thankful, maybe someone else is in the same case as me

Tagged:

Comments

This discussion has been closed.