ROG PHONE 5 DIED??? HELP !!

Please tell us some basic information before asking for help:

  1. Model Name: ROG PHONE 5 ZS673KS
  2. Firmware Version: I dont know
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: First time
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Yesterday, after a normal session of gaming i saw i had low battery (1%) and just ran to charge my phone, but it turned off before i arrived to charge it. So i just connected it to charger as normal and it didn’t showed anything like it was charging but i just go sleep and today im seeing the phone dont turn on again! and it still without show anything saying its charging… tried everything like press volume button + power etc but still not working, it dont show anything apart of black screen and for real one second before it turned off due to battery it was working perfect (the cable of the charger isnt the problem i just tried it with other devices and other cables with the rog phone in other places etc and nothing work) NEED URGENTLY ANY HELP BECOUSE I NEED THE PHONE DAILY TO BE ABLE TO PLAY AND STREAM WITH IT, Thanks in advance🙏🏼

Comments

  • Disconnect the charger from the mains, reconnect it after 15-30 seconds then connect the usb-c cable to the rog 5

    Wait 30 seconds, if the led does not light up, try another charger or the USB port of a PC

    If that doesn't work, I think you won a visit to the service center :(

  • @FunBike31 tried and dont see the red light of charging :( btw i the charger isnt the problem becouse i tried with others phones and charge them… but have no sense it just dont turn on again when 1 second before it turned off (due to low battery) i was using it as normally… Can’t do anything else before send it to the service center? it will take too long till have it back🥲

  • Press and hold all buttons during 15 sec.

  • He specified that it is off when he saw that he had 1% left

    and that it wasn't charging when he plugged it in before going to sleep, so no chance it would turn on. it can however help to empty the circuit and unblock the load if the failure is not material.

  • In the morning when you woke up, you didn't smell anything abnormal like a burning smell? if so, there is nothing attempted, only the service center.


    I also think that the charger is not in question, to disconnect it from the sector is to reinitialize the software.

    there is a small chance that the circuit is ok and therefore just the battery software. Try to find a charger as standard as possible (1 or 2 A) or a USB port and do a few tests.

    When the battery is at 0%, it may take several minutes before the indicator turns red. (it lights up very very weak at the start)

    FYI, it happened to 1 user, the Smartphone is put back to charge after 24 hours without being connected, I hope you will have as much luck.

  • @FunBike31 first of all thank u very much for all the answers, and no, i didn’t smell anything when woke up. What do u mean with 1 or 2 A charger?? i use official Rog 5 charger and tried too the Red Magic charger and still without work. What should i do right now until im able to send it to service center?? like let it 24 h without charge or what do you recommend you bro?

  • Have you tried charging from the side port?

  • A 1A charger is a non-fast charger, an old thing you might have in your closet, the software and security are less advanced, this makes it easier to talk to the rog5 software which seems to be stuck. In short, it is possible to supply a little electricity to the rog5 for a few moments.

    I have referenced several cases of malfunction on the charge of the rog5, I myself have 3 different bugs including 1 with a charger or the rog 5 does not require electricity from the charger.

    There are users or the battery is used or charging but the display remains blocked at 81% and others at 100%, the solution to regain a normal charge is a factory reset, but unpleasant for you since you have 0%.

    The goal would be to get to send it 2 or 3%, which can be done with multiple connections / disconnections to the charger which must supply 0.5A for a few seconds, if it is indeed a software failure.

    As it is the weekend, you can test as many things as possible

    before sending it back to a service center if nothing works.

    In any case, do not leave it for more than 5 minutes connected to a charger if the LED remains off, in the best case, the charger does not send anything, in the worst case it sends 20v and burns the circuits

  • @FunBike31 all right bro thx, i’ll some differents chargers and things, but one more question, a 1A charger, is the cable or the cable adapter? like i just have 1 cable that is usb-c to usb 3.0, from my red magic, can i put that cable in a different adapter or its the cable which i have to change for one standard ??

  • @ajinkya017 yes yes, ofc i did

  • aucune importance pour le câble tant que ce n'est pas un câble qui fait que donnée et qu'il a un connecteur usb-c pour le tél, c'est bon.

  • Hi @ceesartorreess,

    Sorry to hear that. If your device is still unresponsive after trying different chargers, your best bet is to contact a local ASUS service center and have them take a look at your device.

    I will also send you a PM with some further questions, check your inbox.

  • Same thing happened to me . Last I charged my phone on 30 October. And when I tried to charge last night which is 2nd November it didn’t work. My phone was only 3 months old . Tried every possible troubleshooting but still nothing. Don’t know what to do now.

Sign In or Register to comment.