Changing OS System to Linux Opensuse but SSD is still not recognized

rherbertrherbert Level 1
edited June 4 in VivoBook
  1. System: 20GB Ram 1tb ssd 2tb hdd
  2. Battery or AC: Both
  3. Model: Vivobook A15 F512J
  4. Frequency of occurrence: constant
  5. Reset OS: not/yet
  6. Screenshot or video:

========================

Detailed description:I am removing windows and installing linux opensuse for a USB boot. I can not get access to the ssd drive. It does not show up and when I probe around with folders I found I do not have permission to access it. I need to scrub my notebook and have access to ssd and hdd drives to install linux. How to I get acces sto my ssd drive?

Comments

  • edited May 3

    try to change disable uefi mode, disable security boot in bios , then boot usb drive , try to install on ssd .

    or

    try to change enable uefi mode, enable security boot in bios , then boot usb drive , try to install on ssd .

    or

    make bootable linux os pendrive as GPT type and then try to change enable uefi mode, enable security boot in bios , then boot usb drive , try to install on ssd .

    or

    make bootable linux os pendrive as MBR type and then try to change disable uefi mode, disable security boot in bios , then boot usb drive , try to install on ssd .


    Note use RUFUS software to make bootable Pendrive


  • rherbertrherbert Level 1

    I had already (1) disabled fast boot and (2) disabled secure boot. I have not been able to locate uefi in bios to disable it. I have tried with a usb boot for fedora and opensuse tumbleweed. I cannot try to install on my notebook's ssd since that is the drive that does not show up even when running gnome disc utilities from a usb boot of fedora.

    When I run fedora off a usb boot and open up folders, I am able to find "Computer" [ssd] and "DATA[HDD]" [hdd] drives but when view I select properties I can access my hdd drive but not my ssd since I am not the owner of "root" and I do not have permission. I did look around in my notebook, with windows running, and noted that my ssd [OS(C:)] is owned by "TrustedInstaller" and I cannot change ownership. Also, do not have access to my EFI System Partition on C:.

    Is there something to enable/disable/select in Bios to reveal an option to diable uefi? I will give it a try but "permissions" and "ownership" will not be affected by uefi.

    As for a pendrive, that will not affect ownership either.

    Thoughts?

  • You already installed windows os on SSD only without extra partitions is SSD.

    so SSD is onwed by trusted installer.. so thats why you cannot access SSD on booting linux.

    if you don't bother about the files on SSD windows os installed then, you need to clean the disk SSD disk.

    follow below steps.

    remove HDD from laptop.

    format SSD using command prompt by blotting windows 10 os dvd.

    remove dvd.

    insert Linux bootable pendrive, boot with this, try to install linux on SSD.

    note before doing above steps , Raed the instruction manual how to install opensuse os opensuse official website.

  • rherbertrherbert Level 1

    I am not concerned about any files on this computer as it was just purchased and has no data on it. I allowed windows to install to dd an image of it [for future firmware updates]. But, I could not do that as I did not have access to my ssd.

    Do I need to remove the hdd [which is empty] to reformat the ssd? It is a reformat since I also need to scrub off the EFI boot partition as well.

    Also, I am not as skilled at this as my notes suggest. In that regard, I do not know what "blotting windows 10 os dvd" is or entails. Nor do I know what/where there is a dvd in my system. Help?

    My install of linux with ssd and hdd is not an issue, done enough of those.

  • edited May 3

    if you don't have windows 10 dvd means , no problem..I will give you direct download link windows 10 iso . you should download and then use Rufus software to Create bootable windows pendrive.

    one pendrive for Windows 10 os.. another pendrive for opensuse os.

    https://software-download.microsoft.com/db/Win10_20H2_v2_English_x64.iso?t=a5732074-e97f-459a-8b88-a551bd88fee6&e=1620126048&h=71e508bf2dc3e9d5be3a5e1365fdce51


    you must remove hdd, because you will get confusion while installing linux os , but if you are advanced technical skilled user means , you can install linux on correct disk say on ssd keeping togther hdd.

    But if you select the wrong disk, then existing data on hdd cannot be recovered.

    Also your laptop is under warranty, opening cover of the laptop, modifying will void the warranty.

  • rherbertrherbert Level 1

    Took me a bit to realize a pendrive = flash drive = thumb drive. I have ISOs of Windows 10 OS and Linux OS and enough USB "pendrives".

    What do I do next? [I have not used Windows much in years so I am uncertain how to scrub drtives with/without a pendrive]

  • rherbertrherbert Level 1

    I am not installing a dual boot. I will install linux as the only OS. After that I will use a virtual machine for windows 10 and the very few programs I still need to access through windows. [I have several Microsoft Windows and Office licenses for virtual machines.]

    The problem I have, and still seem to have, is I need to erase/reformat my ssd drive to gain ownership and be able to install my linux OS and boot on it [hdd will be /home].

    How do I do that? [normally I use gnome disc utlity to erase and then install but I cannot do that here with a "TrustedInstaller" ownership].

  • edited May 3

    boot with bootable windows OS pendrive , click repair your computer , go to command prompt,

    type diskpart and enter,

    list disk

    select disk 0 say ( select disk 0 ) only if you have only ssd

    clean


    see below site how to use diskpart tool

    How to Use DiskPart to Clean and Format a Drive on Windows 10 (makeuseof.com)

  • rherbertrherbert Level 1

    Your help, by the way, is much appreciated and accurate. But, I seem to have confused our discussion a bit. I can handle Linux installs and customizing, which I do regularly. It is gaining access to my ssd drive on my Asus Vivobook 15 that is a problem. How do I erase/format my ssd drive to gain ownership so that I can install Linux?

  • edited May 3

    once completed cleaning, ssd is completly formatted without partitions , it comes as new ssd, shutdown the laptop, remove windows pendrive.

    insert linux bootable pendrive .install linux on ssd

  • rherbertrherbert Level 1

    Appreciate Raju.

  • rherbertrherbert Level 1

    Diskpart did not work. I cleaned both C: (ssd) and D: (hdd) [which were drives 1 and 0 respectively] and then went in to check with a pendrive of fedora containing disk utilities. D: (DATA[HDD]) was quick formatted but C: was still named "Computer" and has Windows OS installed, plus I had not permission to root.

    What else?

  • rherbertrherbert Level 1

    Now I cannot go into the windows installation with D: having been formatted.

  • rherbertrherbert Level 1

    Normally working in command prompts there are different levels of permission. Is there a permission/password level to change to for C: to be formatted perhaps?

  • I tbink you confused. and you didn't know about commands so take your laptop to nearest service center and then ask person to install linux

  • rherbertrherbert Level 1

    I am not confused. I did diskpart from an USB flashdrive with an old copy of windows [Win10_1909]. That may be an issue. However, I am not worng about adminstration levels when entering command prompts. I have read up in "trustedinstaller" and it is a problem for many individuals. I need a password to grant me permission to access and reformat my SSD. There is nothing that can happen at a service centre that cannot be done here or through emails if privacy is a concern. Besides, I am unaware of a "service centre" near me in Atlantic Canada and with Covid 19 restrictions, this forum or email is an appropriate forum.

    Will Asus staff help resolve this problem?

  • I have vivobook 15 X542UQ . .I have downloaded fedora workstation live iso and made bootable pendrive,

    I booted with that pendrive, choosed live fedora, I checked all SSD and HDD can be seen or not, I can able to see Samsung m.2 SSD sata clearly.

    Even in opensuse does not give live option, but opensuse bootable pendrive has detected SSD and HDD also .

    If you had NVme SSD then might not detecting in fedora.

  • rherbertrherbert Level 1

    I appreciate your diligence Raju. First, you work for Asus on this forum - an observation and not a comment. As an Asus employee, you are able to see what my computer is and its components from my product registration, including what SSD is in my computer and what Controller Type/Interface that is set for. But, I have attached screen shots of both by SSD and my HDD drives. I note that it is my HDD that is Port 0. I mention Port as my desktop boots from an SSD on Port 1 (with HDD on Port 2), but when I have a removable HDD plugged into Port 0 ( used for backup) at startup, I am unable to boot as the OS defaults to Port 0.

    As for recognizing and installing, I am unable to install Opensuse and Fedora, but I am also unable to install Win10_20H2_v2. In case it was a problem with my USB flashdrives, I purchased new ones and opened the Win10 iso onto it. That new Win10 USB flashdrive could accesss repair functions but when I attempted to install fresh, the USB flashdrive was not recognized (???) and attempted to reformat the flashdrive.

    I do need to get this SSD up and running or have it replaced with 1 TB SSD that can be accessed. Asus has good products. My 2012 purchase of a 1 TB HDD/AMD A6 laptop is still in use for media. So, I am not upset - but I do need to get this laptop up and running to replace my HP Envy.


  • edited May 5

    Sorry you miss understood. I am not working for asus.

    I am normal laptop user with little knowledge about windows OS.

    I am a teacher and working in govt college.

    form your screenshots , your SSD belongs to NVMe controller and it was enabled in BIOS too.

    So I have doubt NVMe SSD might not deducted, so kindly post your query in fedora community forum and also in opensuse forum.

This discussion has been closed.