A11 major problems with Gmail notifications

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

After updating to A11 I started to see major issues with the battery optimizations, mostly on Gmail app, but once I started to investigate I see it overall. Email notification come with hours , if not tens of hours delay , which was not the case on A10. I noticed that even whether app is not updating in timely fashion.

It looks like phone goes to hibernate and not resumes for notification only once in a couple of hours if not more. Strangely but whatsapp is working fine. I have disabled all battery optimizations and I saw some improvements but not that good as in A10. Yesterday for instance, I lost a couple of important emails since they Gmail App only synchronized once in 10 hours....which is unacceptable.

Factory reset does not help since I have done it at least 7 times due to various issues since A11 update a week ago...


Please help!!!! I don't know what else to look for!

«13456

Comments

  • gazuootgazuoot Level 1

    I also have exactly the same problem, after update my Zenofone 7 Pro to A11 i don't receive any notification from Gmail, other apps work fine. I tryed to change battery optimization for Gmail, uinstaling updates but nothing helps :/. I receive notification only when i open Gmail. At this moment I don' have any idea how to fix this :/

  • edited April 22

    I finally managed to fix, but the fix ain't pretty. I have disabled all battery optimizations (Optiflex, Adaptive battery, hibernate app) and then I still had to go to gmail app and disable battery optimisation for it and for google keep app. If any of these I enable, I don't get notifications...with all these disabled I get notifications. I think it is a combination of google errors plus Asus errors here. I tried all the variants , but nothing else worked. it is pity since all these optimizations were good, but I had no choice here....plus what bothers me most, is that on A10 all worked just fine....

  • gazuootgazuoot Level 1

    Unfortunately, this solution not help me :/. Only way to recieve notification is opening Gmail. This is super annoying :/

  • Strange...are you sure you have disabled all what I mentioned? And also that you set gmail as not optimized? For me it works.... But now I just noticed that calendar also does not send notifications... I am not sure what it's wrong with A11 but google services are failing on this release. I am thinking to return to A10...and block the update...

  • Same issue here with Gmail and Calendar. Also Google's Clock app will not notify me when the timer is done... It just keeps counting in negative until I turn on the screen. It makes the phone borderline unusable. Asus, kindly address this.

  • that's exactly what I was facing on A11 betas!! but I was the only one and they found nothing wrong in my logs :( ...I also disabled all possible battery savers etc (standby battery life is awesome, after night I lose about 2-3%), I disabled battery optimizations on tons of apps, I never enabled app hibernation, I run my device on performance mode but that didn't help

    there were some other apps which were suffering from this (Aggregator RSS reader, Email.cz) but there were others which were delivering notifications on time (Viber, Messenger Lite, Signal for example), I found that it was very random, smth triggered that behaviour and since then I wasn't getting notifications from some apps, I tried switching networks, mobile data, DND mode etc and nothing helped, I always had to reboot to fix that and sometimes it was working fine for a few days but sometimes it stopped working after few minutes and I had to reboot my phone a few times per day

    I also uninstalled all GPServices updates as I was updating that app manually (kind of weird, I know :) ) ...so we can basically say I tried a lot of things but the issue was still there BUT I think it got fixed somehow as the last two updates I don't remember having that issue and believe me that I would immediately notice that as Aggregator app gives me notification almost every 15mins during the day

  • edited April 28

    Well, for me is not working. And apparently, for me only google apps suffer from this.(gmail, calendar). Restart does not help at all. Factory reset either. I think I have reset the phone more than 10 times since I got the A11 update... I am in verge of selling it since I use a lot of google aps, and without notification it is bad...btw I am in latest a11 and here I noticed the issue...and as I posted what I did works for gmail, but calendar app still does not send notifications...what it is even weirder...the calendar app sends notifications for tasks.... For any other type it does not send notifications ...

  • go to settings => apps => Google Calendar and check its notifications settings, there are a few "categories", one is for tasks, another for events etc ;) you may have it disabled

  • I don't know what you are talking about. Settings => apps=> google calendar has no categories for me. Here is a screenshot

    The same is valid for calendar's app settings...

  • I meant switches for calendar notifications and task notifications :) switches is much better than categories in this case :)

  • You lost me! Can you please provide a screen shot?

  • I tried to say that you had it correct, you had both switches enabled in your screenshot - one for calendar and the other for task notifications ;)

  • skipwoofskipwoof Level 1

    Hello Guys

    Same issue for me, with my ZenFone 7 Pro.

    No more notification from Google Calendar. And in the settings nothing has been changed : all notifications are still enabled.

    I tried to remove the app/clear data&cache/disable the app.... nothing solved the issue.

    The thing which is strange : I've a Xiaomi MiBand connected over Bluetooth to my phone => He still send me the Google Calendar notifications. But the phone keeps not showing them (no sound, no notification). So it's like the notification is working, but the ZenFone instantly remove the notification in the phone. Anyone else have a wearable to confirm this behaviour ?

  • I just tested mine with a garmin fenix 3 hr that I wear. I am getting no notification at all from calendar, same as for mobile...

  • Adding to the list, I don't get notifications from instagram app too. I think there are a lot if apps thst don't sent notifications anymore, but I really don't have time to track them all

  • I don't use IG at all so can't confirm that but there are definitely more apps which suffer from this, could it be somehow related to how the notifications are handled in these apps?? I don't know how notifications work in Android but could it be that some apps use GPServices to show notifications and some use different approach??

    I mentioned a few posts above that I haven't faced that issue for quite a long time but that's not true anymore as I had to reboot my device twice last two days to get the notifications working

  • CVonCCVonC Level 2
    edited May 3

    Yeah I've noticed my IG notifications are either not working or lagged.

    Also, SMS notifications seem to come only when I wake up the phone after a deep sleep. Like say I've left it overnight and then look at my phone in the morning when I wake up, only then will the phone alert me of the SMS messages I received hours before. Although I need to test the validity of this observation.

    And I've got the same issue as skipwoof above in that notifications are sent to my Huawei watch (paired with BT) which don't appear on the phone until I wake it up or not even at all.

  • RoystoysRoystoys Level 3

    Has anyone come up with a fix for this problem/ bug yet??

  • RoystoysRoystoys Level 3

    Can you PM me the same log instructions please??

Sign In or Register to comment.