Mouse wireless jumpy and lagging

trudygoldtrudygold Level 1
edited February 5 in ZenBook
  1. System: Windows 10
  2. Battery or AC: AC
  3. Model: UX30UAK
  4. Frequency of occurrence: All the time
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:Hi there, my laptop is suffering from mouse problems. Windows update says it's failed to update a driver and will try again. Postponing this action doesn't seem to make any difference. I can't see which one it is but I suspect it isn't helping. I have run the Asus Live update and Intel driver and support utility. All appears ok. I use two external monitors as well as the laptop screen. Have done for over a year but this problem has only started over the past few months but seems to be getting worse. Hope you can help! Thanks.

Comments

  • edited January 3

    if your wireless mouse comes with Driver cd means, then install that driver, and block the driver updating through windows update.

    Normally wireless mouse connects with laptop or motherboard Bluetooth device, not from a wifi connection.

    check that the Bluetooth device in your laptop having the correct driver,

    check your smartphone able to connect via the Bluetooth device of your laptop perfectly

  • thanks will try it.

  • Hello trudygold,

    May you double confirm the model name?

    and if you use plug in mouse instead of wireless one, does the issue happen?

    how about touchpad?

    Thank you.

  • I had a similar problem and just replaced my mouse

  • The best solution is to use an old USB mouse

  • I just signed up to this forum for this precise issue. I use a BT Logitech mouse, one that worked perfectly with my Samsung Notebook 9 laptop. The mouse will hang where the pointer appears on the screen for a few seconds, then jump down to where it should be. I'm using an Asus ZenBook Flip 15, which is new on the market. Everything else on the laptop seems to work fine, including BT earbuds.

  • Hi All. The problem goes away with a wired mouse. It is currently working ok with wireless, I have done the following, fresh batteries, reinstalled the logitech software and speeded up the graphics on Excel, where I do my work. Maybe this will help someone else. Many thanks to all.

This discussion has been closed.