Worst audio quality output when using stock Android 9 or even worse in Beta Android 10

edited December 2020 in ZenFone Max Pro Series

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_X01BDA
  2. Firmware Version: QKQ1.WW_Phone-17.2018.2007.428-20200903
  3. Rooted or not: No
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I didn't like the audio quality of this phone from beginning even when it is on Android 9. I tried Android 10 Beta 1st and 2nd release and the problem was worse. Then I flashed HAVOC OS 3.9 which gave me lot of features and the audio quality was wonderful and it gave options for audio pre-set in the system settings itself (Kind of an equaliser settings) which indicates hardware is perfect.

But I didn't want to run any custom rom on my phone so I reverted back to stock rom when the 3rd beta release of Android 10 was out. But the audio issue is still worse.

I saw lots of people reporting same issue over and over again but ASUS keeps on saying that they are working hard. But it doesn't look like that. When a 3rd party developer can give a stable rom with all features and good audio quality and the OEM is incapable of doing that is disgusting.

I previously used ASUS Zenfone 5 which used to have a audio Equalizer and the audio was good.

It clearly seems to me that either ASUS is playing around with their users or doesn't intentionally give this feature even though if the device supports so that users are forced to buy more costly phones.

Comments

This discussion has been closed.