[Zenfone Max Pro M1] Battery suddenly stopped working

weiyi169465weiyi169465 Level 1
edited December 2020 in ZenFone Max Pro Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone Max Pro M1
  2. Firmware Version: unsure
  3. Rooted or not: not rooted
  4. Frequency of Occurrence: First time. 09 November 2020. ~1PM (GMT+8)
  5. APP Name & APP Version (If your issue relates to the app): -

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I was using my phone when my phone suddenly switched off when I had about 50% battery left. When I tried switching it on I see the two screens which are 'Powered by android' and 'ASUS', then it just goes to black. It never progresses from there so I thought it required charging.

However, when I tried charging it I get the vibration, the battery charging screen showing the battery at completely empty, and then nothing. It just repeats this cycle every 10 seconds or so, so I just stopped trying to charge it.

I cannot even boot it into safe mode or connect it to my PC to try to retrieve whatever data in it. I don't have the necessary tools to open the back cover to check if anything disconnected by chance.

What happened and what should I do?

Comments

This discussion has been closed.