Mobile data not working on 2009.49

andrewolokandrewolok Level 1
edited November 2020 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: rog phone 2
  2. Firmware Version: 2009.49
  3. Rooted or not: yes, rooted
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I've got my phone back from the service center yesterday and I decided to update it since it was on 2007.27 software version. I got my phone unlocked and rooted and then proceeded to install the full firmware update trough twrp and everything went smooth, updated and got all of my apps and accounts on it. This morning when I went to go out I turned on mobile data and saw nothing on the status bar even though my sim card was activated and works. I tried rebooting multiple times, disabling every magisk module I had but still not working. I even tried reinstalling the update since I had it on my flash drive but still didn't do nothing. With some suggestions I switched APNs to default and again nothing happened. This afternoon I flashed a raw file for version 2007.27 and saw that mobile data worked so thinking something went wrong during the update I reinstalled the update and saw the mobile data not working again. For now I'll be returning to 2007.27 since I need mobile data.

Comments

This discussion has been closed.