Taking 3-4 hours for full charge

edited November 2020 in ZenFone 5 Series

Observing the issue since June 2020. It's taking 3-4 hours for full charge. Fast charging seems not working properly, but sometimes it's working. I mean I could see double ++ symbol while putting my phone in charge,but it's very rare. Is this because of some software/hardware issue or something else ???

Comments

  • It's definitely not a software issue

  • Try blowing some air to charging port & usb c ports but be careful and see if it works as blowing some air will clear some dirt abnormalities

    If still issue remains same try to check with usb c cord change with original adoptor if still same try to check by changing both usb c cord as well as adaptor and see if issue gets solved

    If still issue remains same than its definetly hardware issue take ur device to nearest service centre for further examination but remember Dont forget to backup ur imp data before submitting ur device to service centre

    Thanks!

  • I had this issue, last year. After the updates it was resolved automatically.

    Meanwhile you unplug and plug the charger until it shows ++ symbol while charging.

    Also battery calibration might help you. Search for the steps in web.

  • Hi there, in order to help you kindly help us with the following details:

    1. Kindly update the device to the latest software version.

    2 . Kindly let us know the Charging time taken from 0 - 100%.

    3. What's the charging time difference between the current & previous update.

    4. Try another charger & let us know if there is any difference.

    5. Use the ASUS charger on a different phone & let us know the difference.


    You may also follow the below steps:

    1. Clear system cache.

    2. Try the same under safe mode:

    Hold the power button for 5 seconds => When the screen flashes with option => Press & hold power option => You will get an option to restart in safe mode

    3. If still you face the issue

    factory reset your phone after taking a full backup : https://www.asus.com/support/FAQ/1006346/Hi, we'd request you follow the below steps:

  • I started facing the issue again...


    Any quick solution please?

    It's Not a charger issue

    Tried with another charger to my mobile, same issue. I charged different mobile with my charger, no issues.


    Hence problem with my mobile only..

This discussion has been closed.