Zenbook UM425IA waking from Sleep issue

FletchasusFletchasus Level 1
edited December 2020 in ZenBook
  1. System: UM425IA firmware 304, 305, 306
  2. Battery or AC: Either
  3. Model: UM425IA-NH74
  4. Frequency of occurrence: When waking from sleep
  5. Reset OS: All Windows, ASUS, and AMD drivers up to date for Windows 10
  6. Screenshot or video:

========================

Detailed description:

After putting laptop to sleep using power button, closing lid, or after powWindows er setting timeout, it sometimes will not wake normally. This seems to happen most when the sleep time is more than a few minutes.

Behavior when trying to wake up the laptop is as follows and it does not matter how the laptop was put into sleep ( closing lid, power button, or timeout) or how the attempt to wake was made (opening lid, power button, keyboard, or trackpad):

  1. Screen will be blue background with mouse cursor showing. Trackpad will not move mouse cursor.
  2. Screen will be black with Windows "Hello" eye only on the screen. Sometimes a message will appear saying to dismiss lock screen, but neither keyboard nor track pad will work.
  3. Screen will be black and nothing happens. Power switch light is slowly pulsing.

When any of these three behaviors happen, the laptop will either:

  1. Do nothing until a hard power off is performed and the computer is restarted OR
  2. Will eventually reboot on it's own (this a full reboot, not a wake up). Upon reboot, the track pad is sometimes not responsive OR
  3. Will go to a blue screen with a Windows "Something Happened" message and the laptop will reboot then. This is different from number 2 above in that it has the Windows message.

After oogling and experimenting, it seems like this issue is related to one of the ASUS/AMD services that run at startup. When I disable these (see ng up from sleep works normally. Leaving these services disabled, though, is not an option as without them things like the backlit keyboard and f,utrackpad, nction keys don't work properly.

@Blake_ASUS : Can you check on this?

@vanbako : Have you seen this behavior on your UM425IA?

Comments

  • Hello,

    I had a strange behaviour almost like you a year ago on my ROG PC where enabling nvidia share made my screen unable to react when I lift the panel ... now after several update of nvidia geforce my issue resolved after an nvidia update. So your assumption of a conflict between softwares might be true !

    But are all your PC components updated ?

    So please take a look on the asus update page for your PC :


    Use also the AMD software solution


    I hope it will resolve your issue

  • Thanks, but as mentioned in the heading of the original post, all Microsoft, ASUS, and AMD drivers are up to date (I'm obsessive about that). The graphics are integrated AMD in this model, so there is no nVidia driver involvement. Additionally, the issue has been consistent across the last three firmware updates (latest was yesterday).

  • Hello Fletchasus,

    So this issue only happen when waking up from Sleep mode?

    how about "Hibernate " mode?

    Did you connect any external device to the laptop?

    Thank you.

  • Thanks for your response. I have not used hibernate on this laptop, so it's only occurred when waking from sleep. I did add the hibernate selection to the start menu power options and can try it and let you know what happens.

    I do not have any external devices attached to the laptop and did not have any at any point when seeing this issue.

    Since my original post I did notice one other thing that might be the cause and I will follow up once I've tested further.

    Regards,

    Will

  • FletchasusFletchasus Level 1
    edited September 2020

    @Blake_ASUS it appears that Hibernation wake up works fine. It obviously takes much longer to wake up than sleep would normally and requires pressing the power button (as opposed to just opening the lid or tapping the keyboard like sleep), but there are no issues with the hibernation wake process in the 6 or so times I've tried it.

    Also, I mentioned in my previous post that I had a suspicion about a possible cause for the sleep wake up issue. It turns out that my suspicion was wrong. To complete the thought, what was happening is that after updating the AMD video drivers (Adrenalin 2020), Windows Update was replacing them with an older driver. I turned off Windows updating the drivers and reinstalled the latest AMD drivers, but the sleep issue was still there.

    Does the fact that waking from hibernation is working make diagnosing the problem with waking from sleep any easier to figure out?

    Thanks,

    Will

  • Hello Will,

    Thank you for the update.

    I will consult more about this issue.

    Thank you.

  • I also saw this even after the 306 BIOS update and that it occurs on both Windows and Linux, so I suspect it is a firmware issue.

  • disable hibernation completely .

    adjust the power settings through advanced power settings.

  • Did not enable hibernation until after the problem started and then only at the suggestion of @Blake_ASUS . I had already tried using Windows power settings (including the advanced power settings) to no avail. The only way sleep worked was if I disabled the ASUS and AMD services that run at startup. Unfortunately, disabling those services also disables keyboard backlight, hot keys, etc. and that is not a viable option. My belief at this point is that there is something in one or more of the several ASUS services that is causing a conflict with Windows and it's core power settings.

  • For other people that encounter this issue, there is at least a good workaround on Linux. You can disable the AMD IOMMU with a kernel argument:

    amd_iommu=off

  • Just a quick update for others with this issue. I have been using Hibernate as @Blake_ASUS suggested while waiting for a fix for Sleep. While I'd like for Sleep to work properly, Hibernate is an OK substitute. This laptop is so fast that from tapping the power button while in Hibernate to Windows being completely ready takes less than 7 seconds with Windows Hello. So, while not as instantaneous as proper Sleep wakeup, it's still pretty fast.

    With that said, if @Blake_Asus has an update or other ideas for Sleep, please let us know.

  • I created antoher thread initially to discuss about Bitlocker recovery issue that keeps bugging the laptop where it would start on its own after being shut down and goes into bitlocker blue screen.

    After I manage to reset the laptop and avoid the bitlocker issue (as long as I don't turn off fast startup options) then the wake from sleep starting to become a problem although mine is only blank (black screen) with Windows Hello infrared blinking but the screen never starts.

    I will try the hibernate option and see how it will respond. I haven't really time my machine but from memory, the wake up process was okay when I do it quick enough from the time it goes to sleep. So I assume the problem is quite similar where the laptop having hard time to wake up after certain minutes of sleeping.

  • There were just several updates from Windows when I check the update on my machine last week.

    Seems like after those updates, the wake from sleep is quite responsive. Although there were 2 occasions in the last week where the wake function running quick but once I re-enter the laptop, all browsers and files that I opened before already closed.

  • what device are you using? Is it also UM425IA?

    I here have exactly same issues. I can also confirm that when sleep time is short, a successfull 'awakening' is more likely to happen. In case it slept for an hour or so, there is no chance you can have a smooth wake up.

    I am going to try and stick with hibernation as the topic starter did. Don't quite like the lack of option to wake the device with lid open though.

  • same issue happens on my new laptop UX 425 JA

  • Last week I gave up and sent my UM425IA to ASUS service center in Moscow. They said it would take them up to 20 days to evaluate if it fixable or not, and would they replace it or not. I will let you guys know what service center thinks about this issue once they return my unit to me.

  • I have had similar issues with a completely different laptop. It appears to be a software/config issue with the Windows Hello cam. I was able to get around it by disabling the "automatically dismiss lock screen" feature (in Windows Hello settings).

    So now I have to use a 4 digit pin-code instead, which isn't ideal, but more ideal than the computer crashing if I ever have to resume from hibernation. Might be worth looking into.


  • So, after 10 business days the store where I bought my unit sent me an email and told me that ASUS Service Center has confirmed that this is 'a warranty case', and the store is ready to exchange to any other laptop from their stock. I took Lenovo Yoga Slim 7 14ARE05 instead and even got back ~$100 from price difference. I am completely satisfied with it :)

    Very nice service done by this store, by the way. Notik.ru in case you are buying a laptop in Russia.

This discussion has been closed.