Dropping of Refresh rate Rog 2

Hi...my phone is set on 90hz refresh rate.. but when i enter into settings or any app... Refresh rate drops down , may be less than 60hz , coz it feels very laggy...but after i restart my phone , again everything is buttery smooth... This happened 3- 4 times now, after the latest update. Please help.

«1

Comments


  • I experienced this on previous firmware but not on this latest firmware. The other change I did prior to the latest firmware upgrade was to increase the screen Dpi as I was on 411 and now it is 432. It's probably unlikely the Dpi change affected it.

    Refresh rate and frame rate are two different things. If you are getting frame drops, the device and the connection are not keeping up with each other so you are dropping frames to make up what frames have been loss. If you're having to restart and it is smoother, regular memory clean up should help and don't use extra apps on top for example third party launchers. Launchers (including stock launchers) and icon packs for decorative purpose takes up memory.

  • @Sourabh We're tacking a similar case and you could help us out with a device log. If you're up for it, I can send you instructions via PM.

  • griswaaltgriswaalt Level 1

    Same issue for me too for e.g. while transitioning between screens or scrolling. If I scroll this very page with a gentle flick in Chrome, there's a visible stutter even if my display is at 120Hz. A reboot fixes this for sometime but the issue reappears in a day or two. Would appreciate a fix for this.

    In fact today morning, swiping across my home screen was literally like a slide show. The launcher then crashed and restarted and it was fine. Not sure what's going on. I'm on the latest A10 stable update and have an ultimate edition phone.

  • I have also been experiencing the same with stutters and some lag in apps loading in settings and switching apps. And to be sure this is happening in A10 only, never faced such issues on A9. Also I would somewhat disagree with @ronald1985 of not having custom launchers or icons...might as well buy an iPhone if that was the case with Android. I think the s/w needs more optimization. TRY THIS (not sure it will work 100%). For me stutters have reduced. Open developer setting and tick disable HW overlay (that is enable the settings). This will make all animations processed by GPU.

  • SourabhSourabh Level 2

    I have sent you the log file and screen recording

  • I can confirm this issue. In my opinion it's not the refresh rate changing but there are frame drops, it's very much noticible while scrolling through recent apps, but goes away with restart. I must mention I've changed animation speed in dev options.

  • monilhathimonilhathi Level 1

    Yes same here, they go away with a restart. Slight stutters in recents, even in settings menu are there. I have set anim speed to 0.5x so that should not be the case on stock launcher. I use Nova as well and there is a distinct stutter in recent apps. I'm seeing these stutters on 90Hz and 120Hz as well. I have hard reset the phone twice, once after the June update and once during the first A10 update.

  • SourabhSourabh Level 2
    edited July 9

    Refresh Rate: Before restart


    Refresh Rate: After restart


    I mostly start facing this issue when my phone battery is around 30-35%. Please confirm with you all

  • SourabhSourabh Level 2

    Does this happens only on phones whose developer mode is enabled . Please verify

  • griswaaltgriswaalt Level 1

    Is there any update on this issue?

  • @griswaalt I'm still trying to collect logs from affected users. I'll post an update when I know more.

  • Yes, I am also a ROG 2 user since 6-8 months and I didn't face this issue untill I updated to Android 10... After the update as time passes the refresh rate starts falling down... Like for 24 hours it runs on 120Hz but after the refresh rate starts falling down until I restart the phone... After the restart it again runs smooth for 24 hours and later on still faces issues... Also some of my friends are ROG 2 users and they are also facing same issues after they updated to Android 10..

    @Gustav_ASUS @and06tw

    @Anders_ASUS

  • FYI: I am on 5th July 2020 Android Security Patch level... Which I think must be the latest one

  • YuranYuran Level 1

    Hello all! Do you guys have any updates on this issue?

  • YuranYuran Level 1

    Hello! Please do you how or if this issue has a fix or been fixed? I running on the last update and this lag, fps drop is noticeable. Please any news? Thank you

  • While you're waiting for a fix or a response, may I suggest you turn off bluetooth and swich off mobile/WIFI (leave on what you use) and see if that helps with frame drops?

    Frame drops happen because of latency and if you have less latency, that should ease the affects of frame drops. This happens on high quality graphic games.

  • YuranYuran Level 1

    Hello, the lag is not only in games but in all aroud phone usage. Browsing around the phone options, menus, back and forth, the phone lags a bit, its noticeable, vsynctester.com shows 60fps with the screen set to 90hz for example. Only thing solves the issue is a reboot, then the phone is again butter smooth. Its exactly the same problem that many people have been reporting in this thread and many others. Just would like to know if this issue has been acknowledged by Asus and if smth is beind done. Thanks

Sign In or Register to comment.