Notebook unable to turn off display, goes into sleep mode instead

hqtannedhqtanned Level 1
edited September 2020 in ZenBook
  1. System: Windows 10 Home
  2. Battery or AC: AC
  3. Model: UX331UN
  4. Frequency of occurrence: All the time
  5. Reset OS: Yes
  6. Screenshot or video:

========================

Detailed description: Hi, I've just received back my notebook from the Service Centre and was told that the motherboard was changed. I then brought it back to test, and so I went to reset the PC via the OS itself (I verified with one of the staff and he told me it was okay to do so). I proceeded to leave it on to download overnight until I realize the download did not progress as the notebook had went into sleep mode. I then went to change the sleep settings by putting the sleep to "Never" , and screen to "1 minute" to verify if the display off function is working. After a minute, the notebook went into sleep mode instead of only turning the screen off. I have also tried using the hotkeys "Fn + F7" to turn my display off, but it still goes into sleep mode. I eventually called the Service Centre and highlighted the issue, only to be told that it could be a software issue, which requires me to pay should I proceed on with the repair. They advised me to reformat the OS using an USB flash drive instead of directly reformatting my PC using the OS as it could be corrupted. I have yet to try it out as I'm having doubts as to whether this would work. I've tried to look for solutions online ,but to no avail. If anyone has any insights or is familiar with this issue, I would appreciate your help. Thanks!

«1

Comments

  • hqtannedhqtanned Level 1

    UPDATE : I now realize that even if I were to access the power settings, there's no such option of "Turn off Display". Is there any additional drivers that needs to be installed that I'm not aware of? Thanks.

  • press Window+L if not then decrease the time of window display On in control panel

  • ekarpiczekarpicz Level 1

    Hi


    hqtanned, I've UX331UA. I remember there was issue with ATK Package (ASUS Kerboard Hotkeys) older than 1.0.0060. With 1.0.0060 closing display lid does nothing. Of course if set to do nothing in power settings. I set display lid close action to sleep on battery and to do nothing on AC.

    With older ATK Package, if I recall correctly, and I hope I do, closing the lid was forcing sleep mode disregarding lid close action in power settings. You may try killing corresponding ATK service using task manager to check if it affects display lid close action or not. Start Youtube movie with sound and check if lid close cancels sound and makes power LED blinking. Don't remember which service it was, perhaps just kill them all with ATK-prefix.  Fn+F7 still behaves wrong in ATK 1.0.0060, it oddly forces sleep mode. Fn+F7 should just turn off display, not switch to sleep mode.


    Edward

  • royschreiberroyschreiber Level 1
    edited May 2020

    This is due to Microsoft's "Modern Standby". All types of sleep (including turning off the display) have been replaced with this modern standby, which is probably causing a few of the issues reported here on the forum including the one where the computer doesn't come out of sleep mode.

  • ekarpiczekarpicz Level 1

    Hi,

    indeed there's solution for Win+L (lock) going to sleep. There are two hidden power plan settings, which could be unhidden editing registry. One settings seems being irrelevant to the issue. It's Sleep->System unattended sleep timeout. It's for when Windows wakes PC in the middle of the night to perform updates, unattended sleep timeout specifies timeout for going to sleep after those unattended updates.

    Another hidden setting is Display->Console lock display off timeout. Though setting name is abut display off, but on Modern Standby PC's it also puts PC's to sleep. Default setting is 1 minute. Changing setting to 0 seems fixing issues.

    Oops, I 'm not allowed to paste links.


    Why MS did so? Why users can't lock account and keep downloading something big or calculating/compiling something , which could take long. Everyone needs to be admin

    Edward

  • ekarpiczekarpicz Level 1

    pasting links as text

    onmsft.com/how-to/adjust-windows-10-lock-screen-timeout

    dell.com/community/XPS/XPS-9360-Windows-10-Lock-screen-quickly-goes-to-sleep/td-p/6202320

    Edward

  • I didn't update my windows and had no issues with toggling my display off whenever I want to without my notebook going into sleep mode previously, so I doubt this affected me.

  • hqtanned,

    Perhaps you didn't notice it. I have almost identical to yours UX331UA (just no dedicated graphics) and it from day 1 was going to sleep few seconds soon after closing the lid or locking desktop with Win+L. Display off shortcut Fn+F7 was forcing sleep mode as well. I mistakenly thought I found solution for it with upgraded ATK Hotkey SW. Perhaps Windows upgrade made something to it, certainly not BIOS upgrade.

    Didn't you try playing music using Groove Music or play internet radio using TuneIn Radio with display off? These two are examples of what keeps running from Modern Standby sleep mode.

    Fortunately there is solution to let PC not sleeping with closed display lid and display off, but no solution for Fn+F7 = display off without sleep.

    Edward

  • Hi @hqtanned, please confirm several points below:

    1. When it goes to sleep mode, is your laptop lid is closed? Or does it happens no matter lid is open/closed?
    2. If yes, please try to keep the lid open to see if this is the cause of the issue.

    Please let us know how it goes. Thanks!

  • hqtannedhqtanned Level 1
    edited June 2020

    Hi @AnthonyLee_ASUS,

    When my laptop goes to sleep, it is when my laptop lid is opened. It would be normal for it to enter sleep mode when the lid is closed, since it is the default settings. I have clarified with the power settings without changing anything.

    From what I understand, while I was using the hotkeys (Fn + F7) to toggle off my display when it was still working previously, my laptop only turns off the display as intended. I am certain of this as the LED on the power button remains lit, music on YouTube would continue to play and I could download files with the display off. However now, when I use the same hotkeys (Fn + F7) to turn off my display, the LED on the power button turns to blinking instead, behaving as if it is in sleep mode, making it the same as Fn + F1. To confirm this, I opened YouTube to try to play some music. Just as I pressed Fn + F7 , the music stops playing, confirming that my laptop entered sleep mode, since turning off the display would keep the music playing. I have tried to reset my PC, even did a clean install of Windows and reinstalled the drivers for my laptop model from the ASUS website but the problem persisted.

  • Hi Edward @ekarpicz,

    Please see my latest response and let me know what you think. Thanks.

  • Hi @hqtanned

    I've not yet checked implementation of Modern Standby on many different PC's.

    Today I checked display off on Modern Standby equipped desktop PC with Gigabyte MB using B360 chipset. Modern Standby is really working, but display off just does display off, sleep is entered according to sleep timer. Hidden 'Console lock display off timeout' setting was set to 1 Minute like in our case. It works as expected, just turns off display after lock and doesn't force sleep mode.

    As you may see from the link I provided previously Dell users experience (perhaps experienced) similar issues. Certainly something is wrong either on Asus side or on Microsoft side.

    Edward

  • @RAJU.MSC.MATHEMATICS,


    Nonsense. Hibernation is must have even on ZenBooks. You may not use it, but critical battery action should be allowed to hibernate. Sleep mode keeps discharging and shutdown may lead to data loss. BTW it won't even shutdown if some APP complains that data is not saved. Hibernation is allowed to take place at any given moment.

    I of course will try turning Fast Startup, but I believe it has nothing to do with Fn+F7. If you are suggesting it, did you at least try Fn+F7 with YouTube? You bet it keeps running on ZenBooks?

  • Hello @hqtanned, please check your inbox. Thanks!

  • @RAJU.MSC.MATHEMATICS,

    Fast startup has nothing to do with the issue.

  • Hi @udpsendtofailed

    I have actually tried doing that before. It is essentially the same as changing the value of "CsEnabled" from 1 to 0 in the registry. However, after testing it out for several attempts, there will be an occasion where my laptop does not wake normally like it should. Instead of trying to wake up from sleep, the display continues to be off for a long time while the LED of the power button is lit. I tried pressing anything on the keyboard and it continues to be unresponsive. I had to force shutdown by long pressing on the power button before being able to turn it on again.

  • @udpsendtofailed,

    There should be no practical difference between power usage between DISconnected modern standby and non-modern standby. Switching between dis- and connected sleep is as easy as switching WiFi off or on with Fn+F2.  In older Windows 10 versions there were options in Settings to choose connected or disconnected sleep on battery and mains. They removed it, Interesting why.

    I love how well modern standby works on UX331UA, I like computer sleeping but receiving Skype calls or playing internet radio. Sound on incoming email is good to have too.  It's quite silly to suggest disabling modern standby on each occasion. Perhaps just take power meter and test power usage in all modes before giving such suggestion.

  • Hi @hqtanned & all, we have confirmed that for models supporting modern standby, turning off display will goes to sleep mode as this is the default design by Windows. If you use [Win+L] key, it won't go to sleep mode ( and wait until screen goes out by itself). We have tested that the music from YouTube will keep playing.

    If you're not sure whether your laptop supports modern standby, please refer to this link to find out: https://www.asus.com/support/FAQ/1035447/

    Thanks!

This discussion has been closed.