Usbc port not working properly

I have a new rog phone 2 only 3 months used. Few days ago i started having problems with the main charging port firstly i thought it wasnt working at all but after turning on and off it started charging vut stopped after a while, While turned off it charges fine but not fast charging anymore.

-never used any other charger but the original

-charger works perfectly with other phones

-tried hardreseting the phone all together with no help

Please help

Comments

  • Change the corrupted to new original cable, recheck the charger

  • Please test with another cable first and if that doesn't help, then I'm interested in logging your device

  • "I need your help to troubleshoot this issue. You have a private message (envelope in top right corner) containing a log tool and instructions on how to proceed. Thank you!"

  • I'm a graphic designer working in a studio here in Italy. With the coronavirus emergence and the resulting quarantine, I'm working from home with my personal 2018 Macbook pro 15".

    Everything was fine until this morning, when I've plugged in the AC to charge it up, but it didn't work, in any of the 4 usb-c ports. I've called the technical assistance and they said me to do some kind of diagnostics, but suddently it started to charge up and I was like "oh thank u god".

    So after, like, 1-1,5 hours the battery was charged up and I disconnected the AC adapter (everyone said me that for preseve the battery life I need to make it charge and discharge, instead of leaving it connected), but also my hard drives disconnected! While I was working!

    The OS said that one of my USB connected devices was using too much power and the computer disabled it to preserve the system integrity. I've tried to reconnect my hard drive but they won't connect, it's like they are shut down by the system. I've also tried with a USB stick (which, I suppose, it's less power hungry compared to an hard drive) but it doesn't work. Everything works fine if I have the AC adapter connected, and this is absolutely not good.

    As suggested by technical assistance, I've tried to connect the hard drive in Recovery mode but the result is the same, so I think it's an hardware problem. Next week, when the repair center will be open here in Italy, I will send it in RMA

  • Do you need help with your Apple product or an ASUS phone? If it's the former, then this is not the forum you're looking for (jedi mind trick) :)

  • How about charge with other port ?

    try charge with other cable or adapter and test with other port or try to charge in shutdown mode.

  • @Anders_ASUS , please PM me as well for the log tool as I have been facing inconsistent charging issue recently after the latest update. Sometimes fast charging works but for most of the time I need to use another cable and/or charger.

  • FakhryFakhry Level 1

    @Anders_ASUS , I have the same issue also.

    While I charging my phone, sometimes it connect and sometimes it doesn't connect...

    I've already updated with the android 10 (always update with last FOTA)

    And yesterday, My ROG2 can only charge with slowly (cant fast charging mode like usual) and it took 10 hours to make my battery full.


    Please help my beloved device


    Note: I put my usb A to the charger's headport with a half fill (and thats the only way I only can charge it). Also I already use my S*msung charger, and it connected with fast charging mode but only charge it in only "1 minute".


  • FakhryFakhry Level 1

    Do you already fix the PROBLEM @Yair 😭😭😭

Sign In or Register to comment.