I don't have Android 10

I have a few question

So i heard that zenfone 6 already have android 10 but when i check in the system update it told me that i already have the latest update which is still Android 9.

Is it not out yet on my country (Indonesia)? Or is there an extra step for getting it? If so would you recommend me to update it since I've heard some bad things when they updated it?

Thanks in advance

Comments

  • Apologies for the late response. You have nothing to worry about with Android 10. Quite a few users experienced random bugs and instability after updating, but most of these issues were resolved by backing up their data and performing a factory reset. The rest we are working on fixing.

    You can find the download for Android 10 here: https://www.asus.com/us/Phone/ZenFone-6-ZS630KL/HelpDesk_Download/

    Make sure you are on 1909.194 before you update to Android 10, if not you can find the file for 1909.194 at the same link.

    A guide on how to manually update the firmware is here: https://www.asus.com/us/support/FAQ/1009748/

  • Just one point to make , I also had the same issue. But the Fota update came immediately after I made a local backup.

    I suggest you create a local backup if not yet created, restart your phone and then search for FOTA update.

  • Hello, thanks for the respond

    A week after i made this post the FOTA update came, after i updated it however i got some serious issue like camera not working at all, then some serious overheating then the battery draining fast.

    Noticing this i quickly did some backup and factory clean my phone, and seem to fix all of the problem(i hope)

    Thanks for the answers tho, just want to let you guys know

  • _jis__jis_ Level 5

    @gilraldi

    On the contrary, we must thank you for letting us know how it worked out and how you solved it. Quite often, users write here that they have a problem and we will never hear anything from them again, although they get all kinds of support from other users and it would be interesting for others to know what finally helped and what was the right solution.

Sign In or Register to comment.