cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with accessibility services and app running in background

Anonymous
Not applicable
Please tell us some basic information before asking for help:
Model Name: Rog Phone 3
Firmware Version: 18.0410.2108.158
Rooted or not: nope
Frequency of Occurrence: always
APP Name & APP Version (If your issue relates to the app): Force Stop Apps / Calculator
In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.
========================================
Kia Ora / Heya,

I've noticed that after the upgrade to .158 (yes with factory reset), the accessibility isn't working properly.
In order to reproduce this go to accessibility and enable one of the services listed there, the service doesn't activate until you toggle disable and enable. In summary, in order to activate it, you need to do it twice.
forcestop.jpeg

The Calculator application starts automatically even though I force stop it, this didn't happen before. Yes, it's got all settings to prevent this from restarting automatically, it's battery optimised, clear cache and date, etc.

Chur


5 REPLIES 5

Gustav_ASUS
Community Legend III
@Megalox I'm unable to replicate this on my device. Can you upload a screen recording for us to look at?

Anonymous
Not applicable
Sure thing, here you are

Anonymous
Not applicable
Hey there,
I've tested further and here you are my findings:
When I turning off/on or restarting the phone; then I try the app, the issue doesn't happen. After that, I try the service again and the issue appears again and it's consistent until I turn off/restart the phone.
In order to rule out the application, I've tested the same latest version of the application on another Android versions: 6.0.1 and 10. The service/app works fine.
Thanks

ronald1985
Community Legend I
Megalox

Hey there,

I've tested further and here you are my findings:

When I turning off/on or restarting the phone; then I try the app, the issue doesn't happen. After that, I try the service again and the issue appears again and it's consistent until I turn off/restart the phone.

In order to rule out the application, I've tested the same latest version of the application on another Android versions: 6.0.1 and 10. The service/app works fine.

Thanks


View post
Try setting the Accessibility app to be excluded from any battery optimizations. i.e. Battery Master.