cancel
Showing results for 
Search instead for 
Did you mean: 

keyboard and graphics not working on TUF A617NS-N3085SW

sentenza84
Star I

I actually run Ubuntu 22.04 and bought asus, while they actually advertised this as linux compatabil.

Problem is here, graphics aren't supported yet, get a fatal error on initialization.

 

even worse, is that the internal keyboard is not working.

but a little weird, some of the hotkeys work (brightness / touchpad)

the keybard is working during boot, but not after got to the initial login screen (password can't type in)

external keyboard is working fine.

i tried with ubuntu 18.04, but the results are worse.

 

dmesg gives me the following errors:

[ 0.267007] ACPI BIOS Error (bug): Failure creating named object [\_TZ.TZ01], AE_ALREADY_EXISTS (20220331/dswload2-326)
[ 0.267012] fbcon: Taking over console
[ 0.267021] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20220331/psobject-220)
[ 0.267024] ACPI: Skipping parse of AML opcode: ThermalZone (0x5B85)
[ 0.269182] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GPP2], AE_NOT_FOUND (20220331/dswload2-162)
[ 0.269186] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20220331/psobject-220)
[ 0.269188] ACPI: Skipping parse of AML opcode: Scope (0x0010)
[ 0.269189] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GPP2.WWAN], AE_NOT_FOUND (20220331/dswload2-162)
[ 0.269192] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20220331/psobject-220)
[ 0.269194] ACPI: Skipping parse of AML opcode: Scope (0x0010)
[ 0.269428] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP6.WLAN._S0W], AE_ALREADY_EXISTS (20220331/dswload2-326)
[ 0.269431] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20220331/psobject-220)
[ 0.269433] ACPI: Skipping parse of AML opcode: Method (0x0014)

[ 0.973720] hub 6-0:1.0: config failed, hub doesn't have any ports! (err -19)

[ 4.317465] amdgpu 0000:03:00.0: amdgpu: Failed to add dm ip block(DCE_HWIP:0x30201)
[ 4.317487] amdgpu 0000:03:00.0: amdgpu: Fatal error during GPU init

 

I'll attach the full output as file.

I need this laptop for work and that is not given in the current state.

had to switch to my old lenovo again.

 

 

 

1 REPLY 1

ZenBot
Community Manager
Community Manager
Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.