Showing results for 
Search instead for 
Did you mean: 

ROG Strix B650-A wifi antenna provided isn't recoginzed by system anywhere

Star I

W11 64b

Ground up build

Just got it all together.  I can't get the system to recognize the provided wifi antenna with the ROG Strix B650-A mobo.  The antenna that screws into the back.  If I use the USB antenna off of my old system, everything works perfectly fine.  I used the USB one through windows setup and up to now.

If there is something in BIOS that I need to mess with, I have no clue what I'm looking for.

I went onto the ASUS site and downloaded the wifi driver package.  When I run it from the zip, it says that it isn't compatible with my version of windows.  Even though I selected W11 64b.

If I extract it to a folder, the installer pops up asking if I want to allow the program to make changes to my system.  I click yes.  The window closes and...nothing happens.  There isn't even anything in the task manager that I can see.  I've let it sit there for 10 minutes, thinking maybe it was just doing something in the background and the program was bogged down.  Nothing.

I don't want to use the USB one because my old system is going to my daughter.


Star I

I got it to work.  The BIOS was out of date, by about 4 patches, and an update fixed it.

Hello, @Geawiel 

I'm glad you were able to pinpoint the problem. 
For similar troubleshooting methods, you may refer to the "[Motherboard] Troubleshooting - How to fix Motherboard WI-FI connect problem" guide.
We also recommend prioritizing the verification of drivers and BIOS versions and clearing the CMOS before rechecking the issue.
Additionally, we have another official forum dedicated to discussions on ROG or TUF series products: ROG forum

Thank you.