Showing results for 
Search instead for 
Did you mean: 

Motherboard PRIME A320M-K Windows 10 BSOD

Star I

Long time ago I started a new message, about to a PRIME A320M-K motherboard, with troubles as; BIOS boot process, halted with "F2" "DEL" screen and OS windows 10 it restarted with the Blue Screen Of Dead screen BSOD.

As support replies with ambiguous replies and happens more often Windows 10 BSOD failure and check visible flaws on motherboard and so on connectors and so others, I come to me the idea by remove one of memory bank.

What happened?

The failure ceased, if someone could think saying it was the memory bank, I have swap memory banks with the same result (No BSOD).

Clearly seems problem becomes ASUS, so I inform to ASUS support. What was response?

Ambiguous responses, update bios and others software drivers (check MEMORY / DEVICE COMPATIBILITY) and claim again who sold motherboard dealer.

I told the support agent this kind of issue should be analyzed by engineering side at ASUS factory with no further response.

As said, buying an ASUS product is and will be a headache and waste of money for nothing.


Thanks again.

About BSOD troubleshooting it have been made for many times (please believe me) “Reinstall drivers or restore the operating system, ensuring correct operational steps” by updating drives (device manager screen, roll back), by installed a different WINDOWS 10 OS (Enterprise Student, etc.) and about “Disconnect external hardware devices” no have any external devices (just a desktop computer which used for text editor and internet).
Included have followed recommendation of BSOD event 41 Kernel-Power and "sfc /scannow and chkdsk /f".
As remove one of the RAM memories it stops BSOD but it causes a long time to boot, it takes 7 minutes and 22 seconds, crazy!! an old PC with 2 core 8GB memory with Windows 7 it takes average time about 15 % to boot.
That’s reason of why I’m still o0n the way to try by updating BIOS, but as have tried by different ways, by pendrive formatting (fat32, etc.) with and without renaming “BIOS renamer” file, and even with BIOS windows update tools all without any success.
I’m not the only users which have trouble with the BIOS update on any internet search, it can find numerous of users with the same issue and question and any demo video (included ASUS BIOS update videos) all without make it works.
Have about BIOS update trouble investigated by ASUS headquarters?

PD: I have tried to get in touch with local service, by email and telephone call, both without any answer (telephone call it put in hold after greeting message without some pick up the hold).

Hello, @Ricardo_63 

Since the assistance involves personal information verification, I have DMed you.
Please check the top-right corner for the in-box message and confirm.

Thank you.