Asus Zenfone Max Pro M2 stuck on asus logo suddenly



  • Hello guys, I also got stuck with this problem from March 30th. I didn't realise that Asus was such a shit brand. Most of them it happend at the edge of there warranty ends. I haven't seen such a shit brand anywhere. Bought phone for 14k and just after 1 year motherboard change by paying almost half of what already paid. I really regret for paying this shit on that big billion days.

  • Hello There, so you repair the device from the service center

    How much they charge you?

    How much time they took to repair the device?

  • I am trying now unlock bootloader of my Max pro M2 but whenever I tried to unlock CMD command not working properly it stuck on like still waiting for device and built type is user I don't know what is that issue . And officially I tried by Asus unlock device tool officially download the size of app is 723kb from Asus website but whenevrr I press on unlock button

  • ap6262997ap6262997 Level 1
    edited May 2020

    I am facing same problem in january I had visited to service centre they said that"We have change motherboard and charge about RS 11,000".

    I want to know its really motherboard problem because my phone is responding to minimal adb?

    plzz tell me??

  • I am also thinking we are trapped it is due to new asus update and no genuin solution yet not even on their service centre.

    I don't think changing mother board is proper solution and it is too much costly.

  • Such a shitty brand. Regretting a lot for purchasing it

  • ArshinArshin Level 1
    edited May 2020

    thanks for your help.

  • giegie Level 1
    I've reccently suffer same issues.. stuck on ASUS logo while restart.. 
    Is there any solution from ASUS on this issues? or they want to make profit about this issues,
    it might be influence buyers to buy Asus products in the future if they don't do something about it

  • It is the same as what happened to my Asus Zenfone max pro m2 after a few days after it is updated it shuts down and whenever I tried restarting it gets stuck with Asus logo only, now it is working after a few days but the power button is not working anymore, I almost smashed it due to frustration because I use my phone to work due to lockdown and everything I need is in my phone, I hope Asus test everything first before they launch any updates

  • It's a motherboard issue in which you have to change motherboard which cost around 11000₹ ,so asus has to do something as it in any bug by their update and when I diagnose my phone in market they said that it's a bug which destroys Boot IC chip and service center never work on chip level they directly change full board ,so there is waste of money and time to visit service center with a diagnosis charge

  • No ,you have to change your mother board which cost around 11000.i have same issue when I visited to service center they said to me the same

  • my zenfone max pro 2 also stuck on asus logo

    and i went to service center they are all illitrate and he says me to change mother board .

    so please tell me were i go or put some instrution on your website with stock rom .so i and all my friends repair itself

  • Middle fingure to all the basterds and assholes behind this brand. They are trying everything possible to take money from people. The worst mobile brand in the world. Worst servie centre experiences. #BoycotAsus campaign already started in Facebook Paying half of the price of mobile just after one year to change motherboard. Phew..! Perverts

  • Just keep backup of your data I have lost my data and my device is still stuck at boot logo

  • Please contact me at [email protected] I'm also having same problem, I was just uninstalling some apps like instagram and suddenly my phone freezed and it was doing nothing so I tried to reboot it, and it is not turning on and stuck at asus logo only, My data is very important for me I just want my data back, is there any way to get my internal memory data back? I can access stock recovery mode and csc fastboot mode only and the devices shows a message in recovery mode that couldn't load bitmap fill_ball (error -7) supported api : 3

    I don't know what is the problem with that...

    I have seen one method to backup data using adb pull request.

    can you help me please I'm ready to pay more than 50,000Rs for that data...!!! It is very important for me.

  • Same problem...service center told to change motherboard.. I put the phone in there dust bin...almost slapped the service center employee.. Now at police station waiting for a lawyer

This discussion has been closed.