Bottom Type-C Port not charging, overheats in seconds and smells burnt/short circuit

edited September 2020 in ROG Phone 2

My ROG Phone 2 12gbRAM/512ROM global won't charge when using the original 30w charger and cable, the bottom port not only won't charge or detect the cable, it heats up quickly and after removing the cable from the bottom type- c port, it smelled burnt or short circuit electrical socket. A notification alerted me of high temperature and needs to be checked at a service center.

I turned off my phone to cool it down. Then turned it on again

I then tried to plug (again at the bottom port) a 32gb usb type-c flash drive and was able to transfer files. After the flash drive, i plugged an earphones with a type-c cable (not the 3.5mm jack) and i was able to hear both ear piece producing sound.

I tried to charge again at the bottom port, and with no luck it's not charging but it heats up and i can smell something like a burned electric cable at the bottom port. Right now i am charging at the side port (hypercharge) (is it true that it is not recommended to charge at the side port?)

Can someone help me?


  • There's no issue charging with the side port but you should contact your local ASUS Support for a repair

  • RamsesRamses Level 1
    edited August 2020

    Same here just today! It hasn't been a year since i have this phone, very sad and stress. I can't get it fix since service center is close! I'm afraid to charge it after this reminder pop ups. The charge port (below) heats up in matter of seconds! The heat is no joke! After unplugging, the tip of the cable is really hot that your finger will get burn if you touch it longer. Is it hardware problem?

This discussion has been closed.