ZenFone 9 "Screen cast" or "Cast to" Not working

Please tell us some basic information before asking for help:

  1. Model Name: ZenFone 9 (UK Version) 16GB/256GB
  2. Firmware Version: WW_32.2050.2050.29
  3. Rooted or not: NO
  4. Frequency of Occurrence: ALWAYS
  5. APP Name & APP Version (If your issue relates to the app): SCREEN CAST

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================


Been trying to get the Android 12 "Screen Cast" feature to share my phone's screen but without success.

I've not really tried until today but it seems this feature isn't working.

I am connected to the same WiFi network as other devices and can "see them" to try to cast but am unable to get them to connect.

It just stays in the "connecting" state forever.

Router model Asus DSL-AX82U updated with latest firmware.

I've tried on my Lenovo tablet and other phones in the house and they all work fine but my new ZenFone 9 (Android 12) just won't connect.

My phone is updated with the latest software version (WW_32.2050.2050.29) and is completely stock, none rooted etc.

It seems that it will not connect to any "Google" products on my network.

I've rebooted everything and everything is working fine on my network except this ZenFone 9 will not screen cast.

It seems to be isolated to "Google" products (although I only have one none Google product on my network to cast to).

I have Google Chromecast 4K Ultra (old version), Google TV Chromecast 4K (new version), Google Nest Display, Google Nest Mini (speaker) X 3 and NONE of them will connect

However I CAN screen cast to my Samsung TV which works fine.

So there's obviously something wrong with the Google products and this phone/firmware

As mentioned my other tablets and mobiles in the house all DO screen cast to these Google products.

Any help would be appreciated.

I just updated the firmware this morning to the latest software version (and rebooted) so not sure if that has broken this.

I do know last week (at my work) I COULD screen cast to the Google Nest Mini speaker and that worked ok (Asus RT-AC68U). But now I cannot connect to my home Google Nest Mini speaker. So am wondering if something has happened with this last updated???

Any help would be appreciated.

«1

Comments

  • I don't have Google TV, just a Google Chromecast and it works fine, I was able to send screen without problem. Works with Xiaomi MiBox too

  • NetboxNetbox Level 1

    Why delete this if I have a problem and it's not working???


    Just because someone's system works doesn't mean it's the same for everyone.


    There obviously IS an issue because I am unable to cast from my ZenFone to my Chromecast Ultra and Chromecast With Google TV and Nest display and nest Mini speakers.


    However I can cast to my Samsung TV


    So there is a problem somewhere which is causing this.


    Just requesting it gets deleted doesn't solve anything. Thank you


    Why not offer some advice "Kazionator" ????


    My ZenFone is connected to my Asus DSL-AX82U via WiFi 6, 160MHz (although I have tried 80MHz too) and all other devices are connected via WiFi 5 AC 5GHz, but that's the same for my TV as well. The TV works but not the Google devices.


    Just seems very strange and I could screen cast the other day when at work. That was to a nest Mini speaker using screen cast (obviously just got audio output but it worked) that was with an Asus RT-AC68U on WiFi 5.


    Will check on Tuesday if I can still screen cast to that. But it looks like something has broken with this last firmware update for me.


    Also I CAN cast YouTube and VLC media content from my ZenFone 9 to all my devices (including the Chromecasts) without a problem.


    It's just the built in Android "screen cast" that won't connect to the Google devices. But there is nothing to configure or any way to change any settings. It should just work.


    I noticed other people with the ZenFone 8 mentioning similar problems with this feature with Android 12 and their devices which were sorted out after the next firmware update.

  • NetboxNetbox Level 1

    Why delete this when it's a problem???


    It's not working and was before the update.


    Just because someone's works doesn't mean everyone's does.

  • sonorosonoro Level 1

    Kazionator surely didn't mean to delete your topic, but his own text, as he probably posted an answer to the wrong topic. Did already happen to me as well and I couldn't fully remove my comment then 😅

  • Hey @Netbox!

    Thanks for bringing this to our attention. To assist you with this issue, the R&D team will require log details.

    Please follow the below steps to enable the built-in log tool (Bug reporter).

    1.  Open “Calculator APP”

    2.  Enter “.19595+=”

    3.  Select the Log type according to the type of issue you want to capture. “General cases” will work for most issues.

    4.  After your selection the log tool will exit so you can duplicate the issue or wait for it to happen. Try to use the screen recorder to show your issue when possible. If you can't screen record your issue, then please take a screenshot right after the issue has occurred (as a timestamp) so we know where to look in the log.

    5.  Navigate back to the log tool via calculator and Tap "FINISH AND SHARE".

    6. It takes several minutes for the log to generate. You can exit and do other stuff in the meantime. A silent notification will tell you once the process is done. Tap the notification and then the share button to upload the file to Google Drive and share the link with a moderator. Just make sure to change the permission first so that everyone with the link has permission to view it.

    Note: When you're no longer planning on logging your device, enter “.09595+=” in the calculator and the log tool will stop as well as deleting all stored log files. Make sure to share via calculator. The files found in internal storage -> asus_log are not the correct files (they are only 1.2kb)

    You can share the log file with me via PM.

  • Well my first post here was that shortly after the update to WW_32.2050.2050.29 I also noticed this problem. I deleted the post because the next day everything was working. The next day after returning home I again had the problem connecting to Nvidia Shield and Google Home. I rebooted the phone and the problem disappeared. Today, the same thing happened again - a connectivity problem manifested by the phone seeing the devices, starting to connect to them, asking for permission but ultimately unable to connect. I rebooted the phone and the problem disappeared.

    At the moment everything is working, but I suspect that after a few hours the problem will return. I will generate a log then.

  • kikolykikoly Level 6

    You can try the following steps to force stop Google play services.


  • NetboxNetbox Level 1

    Thats exactly the same for me too Kazionator.


    I haven't posted since my initial post because after a reboot it seemed like it was fixed. But today it's not working again and is the exact same problem.

    Cannot cast to my devices, yet all my other phones and tablets can without problems.

    Its only my ZenFone 9 that will not cast. I have tried multiple things to resolve it and only a reboot sorts it, temporarily until it decides to do it again.

    If I reboot the phone casting works and seems ok. I can cast in my home after a reboot, then I got to work and try it there and it's working, come home, try it at home and it's working too. But then all of a sudden it's not working again.


    Completely random it seems but definitely something specific to the ZenFone 9.

  • NetboxNetbox Level 1

    Thanks for the tip kikoly

    That did sort it without a reboot, but it's most probably not a permanent fix. I'm sure it will fail again.

    But at least forcing Google play services to close is easier than a complete reboot.

    There's obviously some issue that is causing this.

    I'll see how long this time before it stops working again. Just no idea really what's causing it as nothing new installed or changed.


    Many thanks

  • NetboxNetbox Level 1

    @Mansi_ASUS


    I've created a log file for my screen cast error and a screen capture video.


    You ask me to DM you, but don't mean to ask a stupid question but how do I DM you.

    I see no option to message you directly so can't send you anything until I know how.

    I'm accessing Zentalk from my ZenFone 9 browser. Do I need to log in on a PC in order to DM you or am I missing the obvious


    Please advise how I can DM you. Thanks

  • NetboxNetbox Level 1

    Further to my previous message.

    Yes forcing Google play services to stop did work, but only for about 5 minutes, then the error was back again straight after. So it wasn't a solution. But thanks for the help.


    Just created a log

    Just need to know how to DM someone on this platform

  • kikolykikoly Level 6

    According to moderators, this is an issue with Google Play Services. Use the forced stop method temporarily until the problem is improved.

  • NetboxNetbox Level 1

    Ahhhh brilliant. Thanks for the info

    Hopefully that might also help fix the Bluetooth issue with my car and ZenFone 9 dropping calls from my car's audio back to my handset too (but that's another story)

  • @Mansi_ASUS Today, the problem has returned. I have sent you the log.

    As advised by @kikoly I disabled google services and the problem disappeared temporarily. This is included at the end of the log.

  • Thanks for the update. I'll forward it to the team.

  • I have the same issue with my ROG Phone 5S Pro trying to connect to a Samsung Smart TV. I used to cast and mirror my phone screen on that TV until I updated my phone a few months ago. I tried using other devices and their casting feature works fine. It's just the ROG Phone connecting and disconnecting right after it connected. I will try that stop Google Services procedure. Did you just Forced stop it or did you disable it completely while using Screen Cast?

  • I can't force stop Google Play Services for an unknown reason. It's already grayed out.

  • I am having the same issues as well, even tried re-updating Google Play Services (removing updates; reinstalling) with no luck.

    Also using YouTube is finicky. it will connect if prompted, but won't if I select chromecast device manually from phone. Also using the TV code method for YouTube has no issues.


    I hardly ever use the screen mirroring feature, but it's really annoying that it doesn't work.

Sign In or Register to comment.