Charging Problems

ooonstooonst Level 1
edited July 7 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: Rog 5s
  2. Firmware Version: WW_18.1220.2202.206
  3. Rooted or not: Not
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): N/A

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

So it looks like there are few possibly software and Hardware bugs to do with Charging this thing.

First thing I noted was that the phone has stopped charging if I plug in the Factory supplied ASUS 60W charger into the bottom or side ports. The LED lights up yellow to (I assume to indicate charging) and the battery icon on the notification bar has a lightning icon inside it (which is quite hard to see - these notification icons are tiny!!) but the battery level... just... goes... nowhere. It doesn't seem to matter if I have steady charging enabled or not, nor which port I use, but what I have noted is that if I have Steady charging turned on, it looks like it detects the supported charger for a second when I connect the USB cable and then it states, your charger doesn't support Steady Charging. If I pull out the cable and plug it back in (sometimes once, sometimes twice, and again doesnt matter which port) it will start charging but the battery notification icons and LED are different: The LED lights up red and the battery notification icon has 2 lightning bolts to the right of it (as opposed to inside). Steady Charging, if enabled, now seems to be working and battery is filling up.

I'm not sure when I first noted this behaviour but probably weeks after getting the thing new (now a couple of months back) and upgrading the OS to this version which is why it's most likely to be a software bug. (Older versions did not have this??)

I have noted that this problem doesn't seem to occur on other, (non-Asus) chargers? So perhaps it's something to do with this version of software interacting with the Asus Charger? Steady Charging Detection is causing it to not charge?


Has this bug been fixed? And has it been fixed in an Android 11 patch as there is no way I'm going back to 12 on this phone. I'm thinking about getting rid of this thing and going back to Samsung as there are way too many issues.

Comments

  • ooonstooonst Level 1

    Further to this, It looks like Steady Charging doesn't seem to actually do anything. It claims that it will take X number of minutes @30W and Y number of minutes @18W but even when set to 30 or 18W it still charges super fast. Like 20 Minutes to go from 20-80% battery.

  • ooonstooonst Level 1

    I'm loving the charging speed (and the awesome battery life) but I would prefer that it simply "did what it said on the tin"...

  • WilljoeWilljoe Level 1

    Troubleshoot with advanced steps

    1. Unplug the cable from the power charger.
    2. Check that your computer is on and connected to a power source.
    3. Connect your phone to your computer's USB port with the cable that came with your phone.
    4. Wait 10–15 minutes.
    5. Disconnect and reconnect the cable from your phone within 10 seconds


    Regards,

    Willjoe

  • ooonstooonst Level 1

    What's plugging it into the PC got to do with the troubleshooting?

Sign In or Register to comment.