ROG Phone 5 can no longer make or receive calls. Calls end immediately after dialing.

WiLd256WiLd256 Level 1
edited May 3 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 5
  2. Firmware Version: 18.0830.2101.86
  3. Rooted or not: No
  4. Frequency of Occurrence: All the time
  5. APP Name & APP Version (If your issue relates to the app): Phone app

=======================================

Hello,

I've had my ROG phone 5 for a little over two months now, however, this is only now starting to become an issue. In the phone app, I can no longer receive calls and trying to send a call to someone results in the call getting ended immediately. I click the contact button, it dials for a split second before the call inexplicably ends. This problem has persisted for two days now and every single fix I have found online hasn't worked so far. I've tried switching sim trays, toggling airplane mode, resetting network settings, messing around with my mobile network settings, and even factory resetting my phone, only for this problem to persist, even though for nearly two months prior to this, my phone functioned perfectly. It isn't a problem with my sim either. After taking out the sim and putting it back into my old iPhone SE, I was able to send and receive calls perfectly fine. I would greatly appreciate a reply because I am going insane. Also, I'm on AT&T if that helps.

Comments

  • WiLd256WiLd256 Level 1

    [Fixed!] Okay, so I think I might be an idiot because installing the most recent firmware update for the phone fixed the problem. So I suppose this issue was my bad.

  • Hi @WiLd256

    Thank you for updating us!

  • I am having the same issue. Everything is completely up to date. I Factory reset my Rog 5 and tried to remove and clean sim card. All other functions work great but incoming and outgoing calls are immediately ended. Any thoughts? Phone is around 3 months old

  • Hi@WiLd256

    How did you installed the newest firm update?

    Many Zenfone users with AT&T have the same issue, including me. Neither AT&T nor ASUS support is helpful.

  • Try reset network settings.

    If you have the tencent model with WW rom it will not likely to work since it's missing US bands.

  • Until someone lets us in on the firmware update the best solution is to put a sim card in Sim 2.

    a nonactive SIM card allows you to to position the data preference to Sim 2 this for some whacky AT&T reason allows sim 1 to make calls. AT&T won’t let us put Two Different Sims on the same number. I asked 033022 if they could put data on one and call on the other so I wouldn’t have to switch back and forth they said NO! But was more then happy to sell me another phone! #%^*

  • When AT&T dropped 3G and their alleged efforts to improve 5G whatever wacky reason they dropped it for or calling capabilities died on the ROG phone five tencent edition.

    AT&T professors that ROG phone five is applicable to their system but they are not willing to make a fix for their mistake they looking for more money so put a blank Sim card in position two or an active one

    a blank one will allow you to switch the data position from SIM card 1 that has both calling and data to position two this will allow position one to call and SMS but no data until you switch the data service preference back to position one then you’ll have internet and SMS with picture send and receive

  • Hey ASUS we the Republic of gamers demand a fix for that issue so that we can once again have our calling

  • What happened to us is AT&T re-provisioned our phones to get us off of the net work they want us to buy their equipment so they taking advantage of the fact that we have ROG phone 5 $.10 addition.

    until a SUS comes up with an update I have a temporary fix for everyone you keep your Sim card in position one with calling and data put a blank Sim card in position to transfer data abilities to Sam too I know Sim two card is blank but for some wacky reason telling the machine that it is in SIM to allows you to call and text from someone when you need your data back revert data back to sim 1

    it works for me

This discussion has been closed.