Rog phone 3 (Tencent edition) USB -C port charging but not recognized on my laptop.(Lenovo)

ah15935711ah15935711 Level 1
edited July 26 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG 3 trncent edition( ZS661KS)
  2. Firmware Version:WW-17.0823.2012.131
  3. Rooted or not: yes ( was trying to root)
  4. Frequency of Occurrence: Got<HARDBRICKED>
  5. APP Name & APP Version (If your issue relates to the app): no app used.(magisk or anything else)

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

My rog phone 3 (tencent), which i brought about 6 months ago. I never had any issues like this.

The other day i opened my camera and suddenly the front camera was not working. I restarted the phone, did factory reset, cleared camera data, but nothing solved the issue. I thought i have to upgrade the firmware. So i downloaded the new firmware (2012.143) and connected the usb c cable with my laptop ( lenovo ideapad 320) , but it did not recognize. i tried both ports. I never had this problem before. I unlocked the bootloader, i thought it might help. I also turned on the developer option and selected FTP protocol and USB debugging. But it still didn't connect. while i was trying to enter bootloader recovery mode I accidently put the phone on EDL mode and now its bricked 😥. The indicator light is flashing when i connect to the pc but the PC isn't recognizing the port ( i downloaded the qualcomm EDL driver on my laptop also, but the port option is not showing at all). Is it hardware problem, But the phone was charging just fine.

please help, gaming is my life😭🙏

Comments

This discussion has been closed.